summaryrefslogtreecommitdiff
path: root/gas/configure.in
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2008-08-24 03:13:05 +0000
committerAlan Modra <amodra@bigpond.net.au>2008-08-24 03:13:05 +0000
commit660909e1c54642597701268c8c18876c524f8be6 (patch)
tree0a9ba39b710844e6933a69aa1a00b596d14d6834 /gas/configure.in
parent3fff843379a9a17496a9b01080d6ec4a24f5bf19 (diff)
downloadbinutils-redhat-660909e1c54642597701268c8c18876c524f8be6.tar.gz
Update a number of obsolete autoconf macros.
Diffstat (limited to 'gas/configure.in')
-rw-r--r--gas/configure.in21
1 files changed, 11 insertions, 10 deletions
diff --git a/gas/configure.in b/gas/configure.in
index 7145dce494..1203893e75 100644
--- a/gas/configure.in
+++ b/gas/configure.in
@@ -5,14 +5,15 @@ dnl brackets, be sure changequote invocations surround it.
dnl
dnl
dnl v2.5 needed for --bindir et al
-AC_PREREQ(2.57)
-AC_INIT(as.h)
+AC_PREREQ(2.59)
+AC_INIT
+AC_CONFIG_SRCDIR(as.h)
dnl Autoconf 2.57 will find the aux dir without this. However, unless
dnl we specify this explicitly, automake-1.7 will assume that ylwrap is in
dnl gas/ instead of gas/../.
AC_CONFIG_AUX_DIR(..)
-AC_CANONICAL_SYSTEM
+AC_CANONICAL_TARGET
AC_ISC_POSIX
changequote(,)dnl
@@ -24,12 +25,12 @@ AC_PROG_CC
AC_GNU_SOURCE
AC_USE_SYSTEM_EXTENSIONS
-AM_PROG_LIBTOOL
+LT_INIT
AC_ARG_ENABLE(targets,
[ --enable-targets alternative target configurations besides the primary],
[case "${enableval}" in
- yes | "") AC_ERROR(enable-targets option must specify target names or 'all')
+ yes | "") AC_MSG_ERROR(enable-targets option must specify target names or 'all')
;;
no) enable_targets= ;;
*) enable_targets=$enableval ;;
@@ -62,7 +63,7 @@ using_cgen=no
AM_BINUTILS_WARNINGS
# Generate a header file
-AM_CONFIG_HEADER(config.h:config.in)
+AC_CONFIG_HEADERS(config.h:config.in)
# If we are on a DOS filesystem, we must use gdb.ini rather than
# .gdbinit.
@@ -225,7 +226,7 @@ changequote(,)dnl
changequote([,])dnl
;;
*)
- AC_ERROR($target_cpu isn't a supported MIPS CPU name)
+ AC_MSG_ERROR($target_cpu isn't a supported MIPS CPU name)
;;
esac
# See whether it's appropriate to set E_MIPS_ABI_O32 for o32
@@ -624,7 +625,7 @@ fi
AC_MSG_RESULT($cross_gas)
dnl ansidecl.h will deal with const
-dnl AC_CONST
+dnl AC_C_CONST
AC_FUNC_ALLOCA
AC_C_INLINE
@@ -637,7 +638,7 @@ AC_CHECK_FUNCS(sbrk)
# do we need the math library?
case "${need_libm}" in
yes)
- AC_CHECK_LIBM
+ LT_LIB_M
AC_SUBST(LIBM)
;;
esac
@@ -679,7 +680,7 @@ GAS_CHECK_DECL_NEEDED(errno, f, int f, [
AC_MSG_CHECKING(for a known getopt prototype in unistd.h)
AC_CACHE_VAL(gas_cv_decl_getopt_unistd_h,
-[AC_TRY_COMPILE([#include <unistd.h>], [extern int getopt (int, char *const*, const char *);],
+[AC_COMPILE_IFELSE([AC_LANG_PROGRAM([#include <unistd.h>], [extern int getopt (int, char *const*, const char *);])],
gas_cv_decl_getopt_unistd_h=yes, gas_cv_decl_getopt_unistd_h=no)])
AC_MSG_RESULT($gas_cv_decl_getopt_unistd_h)
if test $gas_cv_decl_getopt_unistd_h = yes; then