summaryrefslogtreecommitdiff
path: root/gas/configure.in
diff options
context:
space:
mode:
authorTristan Gingold <gingold@adacore.com>2009-09-07 09:15:31 +0000
committerTristan Gingold <gingold@adacore.com>2009-09-07 09:15:31 +0000
commita927089f8c72abe7c76c32d862aa1407642b99f1 (patch)
tree6079922ccb1d752b36fd950afe9d31d1a5f609f8 /gas/configure.in
parent6af85a2fddf56cffc6f6cf2e3e4284be42620de1 (diff)
downloadbinutils-redhat-a927089f8c72abe7c76c32d862aa1407642b99f1.tar.gz
bfd/:
2009-09-07 Tristan Gingold <gingold@adacore.com> * bfd.m4 (BFD_HAVE_TIME_TYPE_MEMBER, BFD_HAVE_SYS_STAT_TYPE_MEMBER): Moved to gas/acinclude.m4 * configure.in: Move tests for tm_gmtoff, st_mtim.tv_sec and st_mtim.tv_nsec to gas/configure.in (bfd_elf64_ia64_vms_vec): Remove vmsutil.lo * configure: Regenerate. * config.in: Regenerate. * vmsutil.c: Moved to gas/config/te-vms.c * vmsutil.h: Removed. * Makefile.am (BFD32_BACKENDS_CFILES): Remove vmsutil.c (BFD32_BACKENDS): Remove vmsutil.lo * Makefile.in: Regenerate. gas/: 2009-09-07 Tristan Gingold <gingold@adacore.com> * Makefile.am (TARG_ENV_CFILES): New variable. Set to te-vms.c (POTFILES): Add $(TARG_ENV_CFILES) in definition. (EXTRA_as_new_SOURCES): Ditto. * Makefile: Regenerate. * acinclude.m4 (BFD_HAVE_TIME_TYPE_MEMBER, BFD_HAVE_SYS_STAT_TYPE_MEMBER): New macro created from bfd/bfd.m4. * configure.in: Add Tests for tm_gmtoff, st_mtim.tv_sec and st_mtim.tv_nsec (from bfd/configure.in). Check for time.h and sys/stat.h headers. Add te-vms.o in extra_objects if te_file is vms. * configure: Regenerate. * config.in: Regenerate. * config/te-vms.c: New file, from bfd/vmsutil.c (vms_dwarf2_file_time_name, vms_dwarf2_file_size_name) (vms_dwarf2_file_name): New functions. (vms_file_stats_name): Make it static, add a dirname parameter to locally create the full pathname. * config/te-vms.h: Add a copyright header. Declare the above functions. (DWARF2_FILE_TIME_NAME, DWARF2_FILE_SIZE_NAME, DWARF2_FILE_NAME): Use the above functions in the definition. * makefile.vms (OBJS): Add te-vms.obj. (te-vms.obj): Create a specific target. * configure.com: Create targ-env.h using a per target value. Compile te-vms.c for ia64.
Diffstat (limited to 'gas/configure.in')
-rw-r--r--gas/configure.in18
1 files changed, 17 insertions, 1 deletions
diff --git a/gas/configure.in b/gas/configure.in
index 7d4da951d0..2c456e0a6a 100644
--- a/gas/configure.in
+++ b/gas/configure.in
@@ -386,6 +386,10 @@ changequote([,])dnl
te_file=$em
fi
+ case ${te_file} in
+ vms) extra_objects="$extra_objects te-vms.o" ;;
+ esac
+
# From target name and format, produce a list of supported emulations.
case ${generic_target}-${fmt} in
@@ -609,7 +613,7 @@ AM_MAINTAINER_MODE
AM_CONDITIONAL(GENINSRC_NEVER, false)
AC_EXEEXT
-AC_CHECK_HEADERS(string.h stdlib.h memory.h strings.h unistd.h stdarg.h varargs.h errno.h sys/types.h limits.h)
+AC_CHECK_HEADERS(string.h stdlib.h memory.h strings.h unistd.h stdarg.h varargs.h errno.h sys/types.h limits.h time.h sys/stat.h)
# Put this here so that autoconf's "cross-compiling" message doesn't confuse
# people who are not cross-compiling but are compiling cross-assemblers.
@@ -697,6 +701,18 @@ AC_CHECK_DECLS([vsnprintf])
BFD_BINARY_FOPEN
+# Support for VMS timestamps via cross compile
+
+if test "$ac_cv_header_time_h" = yes; then
+ GAS_HAVE_TIME_TYPE_MEMBER(struct tm, tm_gmtoff)
+fi
+
+if test "$ac_cv_header_sys_stat_h" = yes; then
+ GAS_HAVE_SYS_STAT_TYPE_MEMBER(struct stat, st_mtim, tv_sec)
+ GAS_HAVE_SYS_STAT_TYPE_MEMBER(struct stat, st_mtim, tv_nsec)
+fi
+
+
dnl Required for html, pdf, install-pdf and install-html targets.
AC_SUBST(datarootdir)
AC_SUBST(docdir)