summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorDavid S. Miller <davem@redhat.com>2008-04-15 05:16:51 +0000
committerDavid S. Miller <davem@redhat.com>2008-04-15 05:16:51 +0000
commit4dcd110f8f33a3438be0e78143d534e0a116d68a (patch)
tree543041f78b982cd592939834934467613d82a445 /gold/Makefile.am
parent38d3da0170e45b95e64a5d4461323020fe90b62d (diff)
downloadbinutils-redhat-4dcd110f8f33a3438be0e78143d534e0a116d68a.tar.gz
toplevel/
* configure.ac: Add sparc*-*-* to gold supported targets. * configure: Regenerate. gold/ * sparc.cc: New file. * Makefile.am (TARGETSOURCES): Add sparc.cc (ALL_TARGETOBJS): Add sparc.$(OBJEXT) * configure.tgt: Document targ_extra_size and targ_extra_big_endian. Add entries for sparc-* and sparc64-*. * configure.ac: Handle targ_extra_size and targ_extra_big_endian. * Makefile.in: Rebuild. * configure: Likewise. * po/POTFILES.in: Likewise. * po/gold.pot: Likewise.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index ea43458453..148999d39f 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -103,10 +103,10 @@ YFILES = \
EXTRA_DIST = yyscript.c yyscript.h
TARGETSOURCES = \
- i386.cc x86_64.cc
+ i386.cc x86_64.cc sparc.cc
ALL_TARGETOBJS = \
- i386.$(OBJEXT) x86_64.$(OBJEXT)
+ i386.$(OBJEXT) x86_64.$(OBJEXT) sparc.$(OBJEXT)
libgold_a_SOURCES = $(CCFILES) $(HFILES) $(YFILES)