summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorDoug Kwan <dougkwan@google.com>2009-12-09 03:02:28 +0000
committerDoug Kwan <dougkwan@google.com>2009-12-09 03:02:28 +0000
commit5675e2552f037988ea6eb2e4ab18698029757670 (patch)
tree85bba34cf1fb78ea3f89d286c30f8f864896ffc6 /gold/Makefile.am
parent91e67550ed9be1b6bc2e18050f6b1c79af67c66f (diff)
downloadbinutils-redhat-5675e2552f037988ea6eb2e4ab18698029757670.tar.gz
2009-12-08 Doug Kwan <dougkwan@google.com>
* Makefile.am (CCFILES): Add attributes.cc and int_encoding.cc. (HFILES): Add attributes.h and int_encoding.h. * Makefile.in: Regenerate. * dwarf_reader.cc (read_unsigned_LEB_128, read_signed_LEB_128): Move function definitions to int_encoding.cc * dwarf_reader.h (read_unsigned_LEB_128, read_signed_LEB_128): Move prototypes to int_encoding.h * reduced_debug_output.cc (int_encoding.h): New include. (write_unsigned_LEB_128, get_length_as_unsigned_LEB_128): Move function definitions to int_encoding.cc (insert_into_vector, read_from_pointer): Move template definitions to int_encoding.h * attributes.cc: New file. * attributes.h: New file. * int_encoding.cc: New file. * int_encoding.h: New file.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index 8f47d639d4..6afca178b4 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -39,6 +39,7 @@ noinst_LIBRARIES = libgold.a
CCFILES = \
archive.cc \
+ attributes.cc \
binary.cc \
common.cc \
compressed_output.cc \
@@ -58,6 +59,7 @@ CCFILES = \
gold-threads.cc \
icf.cc \
incremental.cc \
+ int_encoding.cc \
layout.cc \
mapfile.cc \
merge.cc \
@@ -82,6 +84,7 @@ CCFILES = \
HFILES = \
archive.h \
+ attributes.h \
binary.h \
common.h \
compressed_output.h \
@@ -100,6 +103,7 @@ HFILES = \
gold.h \
gold-threads.h \
icf.h \
+ int_encoding.h \
layout.h \
mapfile.h \
merge.h \