summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-11-03 04:32:00 +0000
committerIan Lance Taylor <ian@airs.com>2011-11-03 04:32:00 +0000
commit70c07c65594bfff9ff81e7cbc7939c2920944fc4 (patch)
tree44fcf6004fddd0e61924cd6b7c15cc33cb1815ca /gold/Makefile.am
parent80f581918a7f3c8c4d232fa64294d4f7358abcfa (diff)
downloadbinutils-redhat-70c07c65594bfff9ff81e7cbc7939c2920944fc4.tar.gz
* configure.ac: Add --with-lib-path option. Define LIB_PATH and
NATIVE_LINKER. * Makefile.am (AM_CPPFLAGS): Define TOOLLIBDIR. * options.cc (General_options::finalize): Use library search path from configure script if specified. If not native and no sysroot, only search TOOLLIBDIR. * options.h (Search_directory::Search_directory): Change name to const std::string&. (General_options::add_to_library_path_with_sysroot): Change arg to const std::string&. * configure, Makefile.in, config.in: Rebuild.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index c1c3588ef0..d121ac444c 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -15,7 +15,7 @@ AM_CPPFLAGS = \
-I$(srcdir) -I$(srcdir)/../include -I$(srcdir)/../elfcpp \
-DLOCALEDIR="\"$(datadir)/locale\"" \
-DBINDIR="\"$(bindir)\"" -DTOOLBINDIR="\"$(tooldir)/bin\"" \
- @INCINTL@
+ -DTOOLLIBDIR="\"$(tooldir)/lib\"" @INCINTL@
LIBIBERTY = ../libiberty/libiberty.a