summaryrefslogtreecommitdiff
path: root/gold/Makefile.am
diff options
context:
space:
mode:
authorIan Lance Taylor <iant@google.com>2006-08-18 22:29:20 +0000
committerIan Lance Taylor <iant@google.com>2006-08-18 22:29:20 +0000
commit973d1d89d15d7fd8acb8e4e6335ce1b6a6aafec3 (patch)
treeed5316d8094437d5ce77bd1137c7ddee6fd8b43c /gold/Makefile.am
parent28b82c911fc239cf57d19b1f57c7dee87cc38081 (diff)
downloadbinutils-redhat-973d1d89d15d7fd8acb8e4e6335ce1b6a6aafec3.tar.gz
Another snapshot of the current state of the sources. Gets to the
point of symbol resolution and can now issue a multiple definition error. Also added target selection infrastructure.
Diffstat (limited to 'gold/Makefile.am')
-rw-r--r--gold/Makefile.am15
1 files changed, 12 insertions, 3 deletions
diff --git a/gold/Makefile.am b/gold/Makefile.am
index acff0a449e..a01aef4aab 100644
--- a/gold/Makefile.am
+++ b/gold/Makefile.am
@@ -17,7 +17,7 @@ INCLUDES = -D_GNU_SOURCE \
noinst_PROGRAMS = ld-new
-CFILES = \
+CCFILES = \
dirsearch.cc \
fileread.cc \
gold.cc \
@@ -25,6 +25,10 @@ CFILES = \
object.cc \
options.cc \
readsyms.cc \
+ resolve.cc \
+ symtab.cc \
+ stringpool.cc \
+ target-select.cc \
workqueue.cc
HFILES = \
@@ -35,20 +39,25 @@ HFILES = \
object.h \
options.h \
readsyms.h \
+ stringpool.h \
symtab.h \
target.h \
targetsize.h \
+ target-select.h \
workqueue.h
+TARGETFILES = \
+ i386.cc
+
OFILES = gold.o options.o
-POTFILES= $(CFILES) $(HFILES)
+POTFILES= $(CCFILES) $(HFILES) $(TARGETFILES)
po/POTFILES.in: @MAINT@ Makefile
for f in $(POTFILES); do echo $$f; done | LC_COLLATE= sort > tmp \
&& mv tmp $(srcdir)/po/POTFILES.in
-ld_new_SOURCES = $(CFILES) $(HFILES)
+ld_new_SOURCES = $(CCFILES) $(HFILES) $(TARGETFILES)
ld_new_DEPENDENCIES = $(LIBINTL_DEP)
ld_new_LDADD = $(LIBINTL)