summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <iant@google.com>2007-10-17 06:24:50 +0000
committerIan Lance Taylor <iant@google.com>2007-10-17 06:24:50 +0000
commit4c929b5c0ba7dd8c0fc69b54fda2afa2bed684c0 (patch)
treead37c7d99c812e0c10f50257c5bfdc305cd11e36 /gold/configure.ac
parent7aee9d2f08cc01882907c72a0ce586183ef4dba8 (diff)
downloadbinutils-redhat-4c929b5c0ba7dd8c0fc69b54fda2afa2bed684c0.tar.gz
Add infrastructure for threading support.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index aefd617470..d8f71dfcb6 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -38,6 +38,21 @@ AC_DEFINE_UNQUOTED(TARGET_SYSTEM_ROOT, "$sysroot",
AC_DEFINE_UNQUOTED(TARGET_SYSTEM_ROOT_RELOCATABLE, $sysroot_relocatable,
[Whether the system root can be relocated])
+dnl For now threads are a configure time option.
+AC_ARG_ENABLE([threads],
+[ --enable-threads multi-threaded linking],
+[case "${enableval}" in
+ yes | "") threads=yes ;;
+ no) threads=no ;;
+ *) threads=yes ;;
+ esac],
+[threads=no])
+if test "$threads" = "yes"; then
+ AC_DEFINE(ENABLE_THREADS, 1,
+ [Define to do multi-threaded linking])
+fi
+AM_CONDITIONAL(THREADS, test "$threads" = "yes")
+
AC_ARG_ENABLE([targets],
[ --enable-targets alternative target configurations],
[case "${enableval}" in