summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-11-03 04:32:00 +0000
committerIan Lance Taylor <ian@airs.com>2011-11-03 04:32:00 +0000
commit70c07c65594bfff9ff81e7cbc7939c2920944fc4 (patch)
tree44fcf6004fddd0e61924cd6b7c15cc33cb1815ca /gold/configure.ac
parent80f581918a7f3c8c4d232fa64294d4f7358abcfa (diff)
downloadbinutils-redhat-70c07c65594bfff9ff81e7cbc7939c2920944fc4.tar.gz
* configure.ac: Add --with-lib-path option. Define LIB_PATH and
NATIVE_LINKER. * Makefile.am (AM_CPPFLAGS): Define TOOLLIBDIR. * options.cc (General_options::finalize): Use library search path from configure script if specified. If not native and no sysroot, only search TOOLLIBDIR. * options.h (Search_directory::Search_directory): Change name to const std::string&. (General_options::add_to_library_path_with_sysroot): Change arg to const std::string&. * configure, Makefile.in, config.in: Rebuild.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 905dbaf1c7..1b46f4a852 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -238,6 +238,20 @@ AC_DEFINE_UNQUOTED(GOLD_DEFAULT_BIG_ENDIAN, $default_big_endian,
AC_DEFINE_UNQUOTED(GOLD_DEFAULT_OSABI, $default_osabi,
[Default OSABI code])
+AC_ARG_WITH(lib-path,
+[ --with-lib-path=dir1:dir2... set default LIB_PATH],
+[case "$withval" in
+ yes) LIB_PATH='"/lib:/usr/lib"' ;;
+ no) LIB_PATH='""' ;;
+ *) LIB_PATH='"'"$withval"'"' ;;
+ esac],
+[LIB_PATH='"::DEFAULT::"'])
+AC_DEFINE_UNQUOTED(LIB_PATH, $LIB_PATH,
+ [Default library search path])
+if test "x$target_alias" = "x" -o "x$host_alias" = "x$target_alias"; then
+ AC_DEFINE(NATIVE_LINKER, 1, [Whether configured as a native linker])
+fi
+
AC_CHECK_TOOL(NM, nm)
AC_PROG_CC