summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2012-09-05 11:01:43 +0000
committerAlan Modra <amodra@bigpond.net.au>2012-09-05 11:01:43 +0000
commit791cd1f002faadc68381d3b2a1453e6c8d883a66 (patch)
treec8f89728d8c3d2358086e84641b559ebb2d47123 /gold/configure.ac
parent86aa1ad01d57266f29edf99f84832b3443a58d45 (diff)
downloadbinutils-redhat-791cd1f002faadc68381d3b2a1453e6c8d883a66.tar.gz
* configure.ac (FN_PTRS_IN_SO_WITHOUT_PIC): False for powerpc.
* configure: Regenerate. * testsuite/Makefile.am (final_layout.stdout): Pass --synthetic to nm. (plugin_final_layout.stdout): Likewise. (memory_test): Set page sizes to 0x1000. * testsuite/Makefile.in: Regenerate. * testsuite/discard_locals_test.sh: Add FIXME comment. * testsuite/justsyms_exec.c: Disable function test for powerpc64. * testsuite/pr14265.t: Add .got output section statement. * testsuite/script_test_2.t: Likewise. * testsuite/script_test_3.t: Likewise. * testsuite/script_test_4.t: Likewise. * testsuite/script_test_5.t: Likewise. * testsuite/script_test_6.t: Likewise. * testsuite/script_test_7.t: Likewise. * testsuite/script_test_9.t: Likewise.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 05e807b644..69fe209159 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -304,7 +304,7 @@ dnl tell the unittest framework if we're compiling for one of those
dnl targets, so it doesn't try to run the tests that do that.
AM_CONDITIONAL(FN_PTRS_IN_SO_WITHOUT_PIC, [
case $target_cpu in
- i?86) true;;
+ powerpc*) false;;
x86_64) false;;
sparc64) false;;
*) true;;