summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorIan Lance Taylor <ian@airs.com>2011-03-02 14:51:42 +0000
committerIan Lance Taylor <ian@airs.com>2011-03-02 14:51:42 +0000
commit8652dc7bda43d9fc3b6a6fd0e457b7982ce5662b (patch)
tree202abce3218dfae69041faccc3a97d9d50d1de07 /gold/configure.ac
parentca1356355be7309fffcbc3aeb577fd9671574bdd (diff)
downloadbinutils-redhat-8652dc7bda43d9fc3b6a6fd0e457b7982ce5662b.tar.gz
* configure.ac: Add check for gnu_indirect_function support in
the toolchain building binutils. * configure: Rebuild.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 2c50d9741c..60243d0709 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -369,7 +369,7 @@ fi
AC_SUBST(RANDOM_SEED_CFLAGS)
dnl On GNU/Linux ifunc is supported by the dynamic linker in glibc
-dnl 2.11 or later.
+dnl 2.11 or later, and by binutils 2.20.1 or later.
AC_CACHE_CHECK([for glibc >= 2.11], [gold_cv_lib_glibc2_11],
[AC_COMPILE_IFELSE([
#include <features.h>
@@ -378,6 +378,7 @@ error
#elif __GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ < 11)
error
#endif
+__asm__(".type foo, %gnu_indirect_function");
], [gold_cv_lib_glibc2_11=yes], [gold_cv_lib_glibc2_11=no])])
AM_CONDITIONAL(IFUNC, test "$gold_cv_lib_glibc2_11" = "yes")