summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorespindola <espindola>2009-12-17 16:02:02 +0000
committerespindola <espindola>2009-12-17 16:02:02 +0000
commitc0b27ff3371a2de2c38d48af62eef80ecdf8fdb2 (patch)
tree566ca675298c7c91fd79dfc4fbf4edde0323b931 /gold/configure.ac
parent9539f952f6935bd79251229d208d1be0443e56b7 (diff)
downloadbinutils-redhat-c0b27ff3371a2de2c38d48af62eef80ecdf8fdb2.tar.gz
2009-12-17 Rafael Avila de Espindola <espindola@google.com>
* Makefile.am (CCFILES): Add timer.cc. (HFILES): Add timer.h. * configure.ac: Check for sysconf and times. * main.cc: include timer.h. (main): Use Timer instead of get_run_time. * timer.cc: New. * timer.h: New. * workqueue.cc: include timer.h. (Workqueue::find_and_run_task): Report user, sys and wall time. * Makefile.in: Regenerate. * config.in: Regenerate. * configure: Regenerate.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 2f9cc43a99..f279b450a2 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -338,7 +338,7 @@ AC_LANG_PUSH(C++)
AC_CHECK_HEADERS(tr1/unordered_set tr1/unordered_map)
AC_CHECK_HEADERS(ext/hash_map ext/hash_set)
AC_CHECK_HEADERS(byteswap.h)
-AC_CHECK_FUNCS(mallinfo posix_fallocate readv)
+AC_CHECK_FUNCS(mallinfo posix_fallocate readv sysconf times)
AC_CHECK_DECLS([basename, ffs, asprintf, vasprintf, snprintf, vsnprintf, strverscmp, strndup, memmem])
# Use of ::std::tr1::unordered_map::rehash causes undefined symbols