summaryrefslogtreecommitdiff
path: root/gold/configure.ac
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@google.com>2012-07-19 00:19:34 +0000
committerCary Coutant <ccoutant@google.com>2012-07-19 00:19:34 +0000
commitd1589410bc292d899b2b707f2b574dbf25a69b86 (patch)
tree799e0ca0b0cd983ab178a1cd5c14a44efabafa03 /gold/configure.ac
parente2a81e0b8d14063ec25bb2cd7ba4f13c5904dacd (diff)
downloadbinutils-redhat-d1589410bc292d899b2b707f2b574dbf25a69b86.tar.gz
2012-07-18 Cary Coutant <ccoutant@google.com>
PR gold/14344 * configure.ac: Add check for -gpubnames support. * configure: Regenerate. * testsuite/Makefile.am (gdb_index_test_1): Add check for -gpubnames support; force -gno-pubnames. (gdb_index_test_2, gdb_index_test_3): Add check for -gpubnames support. (gdb_index_test_4): New test. * testsuite/Makefile.in: Regenerate. * testsuite/gdb_index_test_1.sh: Refactor code into common file. * testsuite/gdb_index_test_2.sh: Likewise. * testsuite/gdb_index_test_3.sh: Don't look for space after colon. * testsuite/gdb_index_test_4.sh: New script. * testsuite/gdb_index_test_comm.sh: New script with common code; don't look for space after colon.
Diffstat (limited to 'gold/configure.ac')
-rw-r--r--gold/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/gold/configure.ac b/gold/configure.ac
index 5e3dc0601c..05e807b644 100644
--- a/gold/configure.ac
+++ b/gold/configure.ac
@@ -562,6 +562,13 @@ if test "$gold_cv_stat_st_mtim" = "yes"; then
[Define if struct stat has a field st_mtim with timespec for mtime])
fi
+dnl Check if gcc supports the -gpubnames option.
+save_CXXFLAGS="$CXXFLAGS"
+CXXFLAGS="$CXXFLAGS -gpubnames"
+AC_COMPILE_IFELSE([int i;], [have_pubnames=yes], [have_pubnames=no])
+CXXFLAGS="$save_CXXFLAGS"
+AM_CONDITIONAL(HAVE_PUBNAMES, test "$have_pubnames" = "yes")
+
AC_LANG_POP(C++)
AC_CHECK_HEADERS(locale.h)