summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2009-06-04 06:57:56 +0000
committerAlan Modra <amodra@bigpond.net.au>2009-06-04 06:57:56 +0000
commit02e1a129e216391b77fbf1c7e85b923da87cce20 (patch)
tree931bd37aa34a47a4831856c453505fec3ff51313 /gprof/Makefile.am
parent3807b79c79114e7209b100dba1bd6c4bc30370a2 (diff)
downloadbinutils-redhat-02e1a129e216391b77fbf1c7e85b923da87cce20.tar.gz
* dep-in.sed: Don't use \n in replacement part of s command.
* Makefile.am (DEP1): LC_ALL for uniq. * Makefile.in: Regenerate.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index a2a42177a2..12d794beed 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -194,7 +194,8 @@ DEP1: $(gprof_SOURCES)
for f in $?; do \
$(MKDEP) $(INCLUDES) $(CFLAGS) $$f > DEPA; \
sed -n -e '1s/: .*/: \\/p' -e q < DEPA >> DEP2; \
- sed -e '1s/.*: //' -f dep.sed < DEPA | LC_ALL=C sort | uniq | \
+ sed -e '1s/.*: //' -f dep.sed < DEPA | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e 's/^[AB]/ /' -e '$$s/ \\$$//' >> DEP2; \
done
rm -f DEPA