summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2007-02-17 13:33:57 +0000
committerJoseph Myers <joseph@codesourcery.com>2007-02-17 13:33:57 +0000
commit6f26604ec294cbd70c5fb7b783dce5ecf214eb07 (patch)
treeeac06a67de807ff05d23772726c21387fa0206e2 /gprof/Makefile.am
parent4bf70a25a92b9994016428d19ef62cd8a38c450f (diff)
downloadbinutils-redhat-6f26604ec294cbd70c5fb7b783dce5ecf214eb07.tar.gz
top level:
2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.ac (TOPLEVEL_CONFIGURE_ARGUMENTS): Fix quoting. * configure: Regenerate. bfd: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.in (--with-pkgversion): New option. * configure: Regenerate. * Makefile.am (bfdver.h): Substitute for @bfd_version_package@. * Makefile.in: Regenerate. * version.h (BFD_VERSION_STRING): Define using @bfd_version_package@. bfd/doc: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * Makefile.in: Regenerate. binutils: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.in (--with-bugurl): New option. * configure: Regenerate. * Makefile.am (REPORT_BUGS_TO): Define. (INCLUDES): Define REPORT_BUGS_TO. Regenerate dependencies. * Makefile.in: Regenerate. * doc/Makefile.in: Regenerate. * bucomm.h: Remove include of bin-bugs.h. * addr2line.c (usage): Don't print empty REPORT_BUGS_TO. * ar.c (usage): Pass s to list_supported_targets. Don't print empty REPORT_BUGS_TO. * coffdump.c (show_usage): Don't print empty REPORT_BUGS_TO. * cxxfilt.c (usage): Print bug url when giving help. * dlltool.c (usage): Likewise. * dllwrap.c (usage): Likewise. * nlmconv.c (show_usage): Don't print empty REPORT_BUGS_TO. * nm.c (usage): Likewise. * objcopy.c (copy_usage, strip_usage): Likewise. * objdump.c (usage): Likewise. * readelf.c ((usage): Likewise. Add STREAM argument. Adjust callers. * size.c (usage): Don't print empty REPORT_BUGS_TO. * srconv.c (show_usage): Likewise. * strings.c (usage): Likewise. * sysdymp.c (show_usage): Likewise. * windres.c (usage): Likewise. gas: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.in (--with-bugurl): New option. * configure: Regenerate. * dep-in.sed: Remove bin-bugs.h. * Makefile.am (REPORT_BUGS_TO): Define. (INCLUDES): Define REPORT_BUGS_TO. (DEP_INCLUDES): Likewise. ($(OBJS)): No longer depend on bin-bugs.h. * Makefile.in: Regenerate. * doc/Makefile.in: Regenerate. * as.c (show_usage): Don't print empty REPORT_BUGS_TO. * as.h: Remove include of bin-bugs.h. gprof: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.in (--with-pkgversion, --with-bugurl): New options. * configure: Regenerate. * Makefile.am (PKGVERSION, REPORT_BUGS_TO): Define. (INCLUDES): Define PKGVERSION and REPORT_BUGS_TO. Regenerate dependencies. * Makefile.in: Regenerate. * gprof.c (usage): Don't print empty REPORT_BUGS_TO. (main): Include PKGVERSION in version output. * gprof.h: Remove include of bin-bugs.h. include: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * bin-bugs.h: Remove. ld: 2007-02-17 Mark Mitchell <mark@codesourcery.com> Nathan Sidwell <nathan@codesourcery.com> Vladimir Prus <vladimir@codesourcery.com Joseph Myers <joseph@codesourcery.com> * configure.in (--with-bugurl): New option. * configure: Regenerate. * Makefile.am (REPORT_BUGS_TO): Define. (INCLUDES): Define REPORT_BUGS_TO. Regenerate dependencies. * Makefile.in: Regenerate. * ld.h: Remove include of bin-bugs.h. * lexsup.c (help): Don't print empty REPORT_BUGS_TO.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am163
1 files changed, 89 insertions, 74 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index ba93be11ee..84ff58a3ba 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -16,7 +16,14 @@ AM_CFLAGS = $(WARN_CFLAGS)
MKDEP = gcc -MM
-INCLUDES = -D_GNU_SOURCE -DDEBUG -I../bfd -I$(srcdir)/../include -I$(srcdir)/../bfd @INCINTL@ -I. -DLOCALEDIR="\"$(datadir)/locale\""
+PKGVERSION = "\"@PKGVERSION@\""
+REPORT_BUGS_TO = "\"@REPORT_BUGS_TO@\""
+
+INCLUDES = -D_GNU_SOURCE -DDEBUG -I../bfd -I$(srcdir)/../include \
+ -I$(srcdir)/../bfd @INCINTL@ -I. \
+ -DPKGVERSION=$(PKGVERSION) \
+ -DREPORT_BUGS_TO=$(REPORT_BUGS_TO) \
+ -DLOCALEDIR="\"$(datadir)/locale\""
bin_PROGRAMS = gprof
@@ -188,112 +195,120 @@ endif
# DO NOT DELETE THIS LINE -- mkdep uses it.
# DO NOT PUT ANYTHING AFTER THIS LINE, IT WILL GO AWAY.
basic_blocks.o: basic_blocks.c $(INCDIR)/libiberty.h \
- $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h \
- $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
- $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h basic_blocks.h \
- corefile.h gmon_io.h gmon_out.h search_list.h source.h \
- symtab.h sym_ids.h
+ $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
+ ../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h basic_blocks.h corefile.h gmon_io.h gmon_out.h \
+ search_list.h source.h symtab.h sym_ids.h
call_graph.o: call_graph.c gprof.h $(BFDDIR)/sysdep.h \
$(INCDIR)/ansidecl.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
+ $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/ansidecl.h \
+ $(INCDIR)/symcat.h ./gconfig.h search_list.h source.h \
symtab.h cg_arcs.h call_graph.h corefile.h gmon_io.h \
gmon_out.h sym_ids.h
cg_arcs.o: cg_arcs.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h call_graph.h cg_arcs.h cg_dfn.h cg_print.h \
- utils.h sym_ids.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h call_graph.h cg_arcs.h \
+ cg_dfn.h cg_print.h utils.h sym_ids.h
cg_dfn.o: cg_dfn.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h cg_arcs.h cg_dfn.h utils.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h cg_arcs.h cg_dfn.h \
+ utils.h
cg_print.o: cg_print.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h cg_arcs.h cg_print.h hist.h utils.h corefile.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h cg_arcs.h cg_print.h \
+ hist.h utils.h corefile.h
corefile.o: corefile.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h corefile.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h corefile.h
gmon_io.o: gmon_io.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h basic_blocks.h \
- corefile.h call_graph.h gmon_io.h gmon_out.h gmon.h \
- hertz.h hist.h $(INCDIR)/libiberty.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ basic_blocks.h corefile.h call_graph.h gmon_io.h gmon_out.h \
+ gmon.h hertz.h hist.h $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h
gprof.o: gprof.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h basic_blocks.h call_graph.h cg_arcs.h cg_print.h \
- corefile.h gmon_io.h hertz.h hist.h sym_ids.h $(INCDIR)/demangle.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h basic_blocks.h call_graph.h \
+ cg_arcs.h cg_print.h corefile.h gmon_io.h hertz.h hist.h \
+ sym_ids.h $(INCDIR)/demangle.h $(INCDIR)/libiberty.h
hertz.o: hertz.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- hertz.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h hertz.h
hist.o: hist.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h $(INCDIR)/fopen-same.h \
- $(INCDIR)/filenames.h ../bfd/bfd.h $(INCDIR)/symcat.h \
- gconfig.h $(INCDIR)/bin-bugs.h search_list.h source.h \
- symtab.h corefile.h gmon_io.h gmon_out.h hist.h sym_ids.h \
- utils.h
+ gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h ../bfd/config.h \
+ $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h ./gconfig.h \
+ search_list.h source.h symtab.h corefile.h gmon_io.h \
+ gmon_out.h hist.h sym_ids.h utils.h
source.o: source.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- $(INCDIR)/libiberty.h search_list.h source.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
+ $(INCDIR)/filenames.h search_list.h source.h
search_list.o: search_list.c $(INCDIR)/libiberty.h \
- $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h \
- $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
- $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h search_list.h
+ $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
+ ../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h
symtab.o: symtab.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h
sym_ids.o: sym_ids.c $(INCDIR)/libiberty.h $(INCDIR)/ansidecl.h \
- $(INCDIR)/safe-ctype.h gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h \
- $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
- $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h search_list.h \
- source.h symtab.h cg_arcs.h sym_ids.h
+ $(INCDIR)/safe-ctype.h gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
+ ../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ sym_ids.h
utils.o: utils.c $(INCDIR)/demangle.h $(INCDIR)/libiberty.h \
- $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h ../bfd/config.h \
- $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h ../bfd/bfd.h \
- $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h search_list.h \
- source.h symtab.h cg_arcs.h utils.h
+ $(INCDIR)/ansidecl.h gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
+ ../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ utils.h
i386.o: i386.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
alpha.o: alpha.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
vax.o: vax.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
tahoe.o: tahoe.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
sparc.o: sparc.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
mips.o: mips.c gprof.h $(BFDDIR)/sysdep.h $(INCDIR)/ansidecl.h \
../bfd/config.h $(INCDIR)/fopen-same.h $(INCDIR)/filenames.h \
- ../bfd/bfd.h $(INCDIR)/symcat.h gconfig.h $(INCDIR)/bin-bugs.h \
- search_list.h source.h symtab.h cg_arcs.h corefile.h \
- hist.h
+ ../bfd/bfd.h $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
+ ./gconfig.h search_list.h source.h symtab.h cg_arcs.h \
+ corefile.h hist.h
flat_bl.o: flat_bl.c $(INCDIR)/ansidecl.h
bsd_callg_bl.o: bsd_callg_bl.c $(INCDIR)/ansidecl.h
fsf_callg_bl.o: fsf_callg_bl.c $(INCDIR)/ansidecl.h