summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorDaniel Jacobowitz <dan@debian.org>2006-12-11 15:09:46 +0000
committerDaniel Jacobowitz <dan@debian.org>2006-12-11 15:09:46 +0000
commit976bae7a9899b0a2b55402ce1482cad5cd89f777 (patch)
treed2a014acfa5656f884862d5a81f94e9aeebeb07a /gprof/Makefile.am
parent13a0f99fdb818599c7f15a6386ee4fa06fff00be (diff)
downloadbinutils-redhat-976bae7a9899b0a2b55402ce1482cad5cd89f777.tar.gz
bfd/
* configure.in: Define GENINSRC_NEVER. * doc/Makefile.am (bfd.info): Remove srcdir prefix. (MAINTAINERCLEANFILES): Add info file. (DISTCLEANFILES): Pretend to add info file. * po/Make-in (.po.gmo): Put gmo files in objdir. * configure, Makefile.in, doc/Makefile.in: Regenerated. binutils/ * configure.in: Define GENINSRC_NEVER. * doc/Makefile.am (MAINTAINERCLEANFILES): Add info file. (DISTCLEANFILES): Pretend to add info file. * po/Make-in (.po.gmo): Put gmo files in objdir. * configure, Makefile.in, doc/Makefile.in: Regenerated. gas/ * configure.in: Define GENINSRC_NEVER. * doc/Makefile.am (as.info): Remove srcdir prefix. (MAINTAINERCLEANFILES): Add info file. (DISTCLEANFILES): Pretend to add info file. * po/Make-in (.po.gmo): Put gmo files in objdir. * configure, Makefile.in, doc/Makefile.in: Regenerated. gprof/ * configure.in: Define GENINSRC_NEVER. * doc/Makefile.am (gprof.info): Remove srcdir prefix. (MAINTAINERCLEANFILES): Add info file. (DISTCLEANFILES): Pretend to add info file. * po/Make-in (.po.gmo): Put gmo files in objdir. * configure, Makefile.in: Regenerated. ld/ * configure.in: Define GENINSRC_NEVER. * doc/Makefile.am (ld.info): Remove srcdir prefix. (MAINTAINERCLEANFILES): Add info file. (DISTCLEANFILES): Pretend to add info file. * po/Make-in (.po.gmo): Put gmo files in objdir. * configure, Makefile.in: Regenerated. opcodes/ * po/Make-in (.po.gmo): Put gmo files in objdir.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index 4e2c88c08c..ea3fa4a1cb 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -61,7 +61,7 @@ POD2MAN = pod2man --center="GNU" --release="binutils-$(VERSION)" --section=1
info_TEXINFOS = gprof.texi
man_MANS = gprof.1
-$(srcdir)/gprof.info: gprof.texi config.texi
+gprof.info: gprof.texi config.texi
config.texi:
echo "@set top_srcdir $(top_srcdir)" >> ./config.texi
@@ -177,6 +177,15 @@ dep-am: DEP
CLEANFILES = dep.sed DEP DEPA DEP1 DEP2
+MAINTAINERCLEANFILES = gprof.info
+
+# Automake 1.9 will only build info files in the objdir if they are
+# mentioned in DISTCLEANFILES. It doesn't have to be unconditional,
+# though, so we use a bogus condition.
+if GENINSRC_NEVER
+DISTCLEANFILES = gprof.info
+endif
+
# DO NOT DELETE THIS LINE -- mkdep uses it.
# DO NOT PUT ANYTHING AFTER THIS LINE, IT WILL GO AWAY.
basic_blocks.o: basic_blocks.c $(INCDIR)/libiberty.h \