summaryrefslogtreecommitdiff
path: root/gprof/Makefile.am
diff options
context:
space:
mode:
authorMark Mitchell <mark@codesourcery.com>2005-11-17 01:01:05 +0000
committerMark Mitchell <mark@codesourcery.com>2005-11-17 01:01:05 +0000
commita777077bf2fc6404c9487676bf1a9aeebc7c5a5a (patch)
treefc1f81ece6e02efea3b27c641328c84c790a6752 /gprof/Makefile.am
parent67e32fe54aa36eb239b3c0ad923102f02eba7404 (diff)
downloadbinutils-redhat-a777077bf2fc6404c9487676bf1a9aeebc7c5a5a.tar.gz
* doc/binutils.texi: Include config.texi and @file documentation
for manual pages. * Makefile.am (gprof.info, gprof.1): Depend on config.texi. (config.texi): New file. * Makefile.in: Regenerated. * Makefile.am (configdoc.texi): Set top_srcdir in configdoc.texi.. * Makefile.in: Regenerated. * ld.texinfo: Include configdoc.texi and ldver.texi in man pages. Add @file documentation.
Diffstat (limited to 'gprof/Makefile.am')
-rw-r--r--gprof/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/gprof/Makefile.am b/gprof/Makefile.am
index f152477be8..a0e782b0fd 100644
--- a/gprof/Makefile.am
+++ b/gprof/Makefile.am
@@ -58,10 +58,15 @@ POD2MAN = pod2man --center="GNU" --release="binutils-$(VERSION)" --section=1
info_TEXINFOS = gprof.texi
man_MANS = gprof.1
+$(srcdir)/gprof.info: gprof.texi config.texi
+
+config.texi:
+ echo "@set top_srcdir $(top_srcdir)" >> ./config.texi
+
# Build the man page from the texinfo file
# The sed command removes the no-adjust Nroff command so that
# the man output looks standard.
-gprof.1: $(srcdir)/gprof.texi
+gprof.1: $(srcdir)/gprof.texi config.texi
touch $@
-$(TEXI2POD) $(MANCONF) -Dgprof < $(srcdir)/gprof.texi > gprof.pod
-($(POD2MAN) gprof.pod | \