summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorRichard Sandiford <rsandifo@nildram.co.uk>2013-06-23 20:08:22 +0000
committerRichard Sandiford <rsandifo@nildram.co.uk>2013-06-23 20:08:22 +0000
commit03ce2d70a48a27aae71820128f00ebf7936f15b5 (patch)
tree61eb5e9859593950d94e3bc8edc4459bf4fbf4c3 /ld/Makefile.am
parent102f380fc0894f1e8815036217304ab1cfb25c07 (diff)
downloadbinutils-redhat-03ce2d70a48a27aae71820128f00ebf7936f15b5.tar.gz
bfd/
* Makefile.am (BFD32_BACKENDS, BFD32_BACKENDS_CFILES): Move MIPS ELF files to... (BFD64_BACKENDS, BFD64_BACKENDS_CFILES): ...here. * Makefile.in: Regenerate. * config.bfd: Enclose all MIPS ELF targets in #ifdef BFD64. Set want64 to true for them at the end. * targets.c (_bfd_target_vector): Protect MIPS ELF targets with #ifdef BFD64. gas/ * config/tc-mips.c: Assert that offsetT and valueT are at least 8 bytes in size. (GPR_SMIN, GPR_SMAX): New macros. (macro, mips_ip): Remove code for 4-byte valueT and offsetT. ld/ * Makefile.am (ALL_EMULATION_SOURCES): Move MIPS ELF emulations to... (ALL_64_EMULATION_SOURCES): ...here. * Makefile.in: Regenerate.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am44
1 files changed, 22 insertions, 22 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index 4766510a52..e85c42a207 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -214,25 +214,11 @@ ALL_EMULATION_SOURCES = \
eelf32_tic6x_elf_be.c \
eelf32_tic6x_elf_le.c \
eelf32am33lin.c \
- eelf32b4300.c \
eelf32bfin.c \
eelf32bfinfd.c \
- eelf32bmip.c \
- eelf32bmipn32.c \
- eelf32bsmip.c \
- eelf32btsmip.c \
- eelf32btsmip_fbsd.c \
- eelf32btsmipn32.c \
- eelf32btsmipn32_fbsd.c \
eelf32cr16.c \
eelf32cr16c.c \
eelf32crx.c \
- eelf32ebmip.c \
- eelf32ebmipvxworks.c \
- eelf32elmip.c \
- eelf32elmipvxworks.c \
- eelf32lr5900.c \
- eelf32lr5900n32.c \
eelf32epiphany.c \
eelf32epiphany_4x4.c \
eelf32fr30.c \
@@ -242,19 +228,12 @@ ALL_EMULATION_SOURCES = \
eelf32ip2k.c \
eelf32iq10.c \
eelf32iq2000.c \
- eelf32l4300.c \
eelf32lm32.c \
eelf32lm32fd.c \
- eelf32lmip.c \
eelf32lppc.c \
eelf32lppclinux.c \
eelf32lppcnto.c \
eelf32lppcsim.c \
- eelf32lsmip.c \
- eelf32ltsmip.c \
- eelf32ltsmip_fbsd.c \
- eelf32ltsmipn32.c \
- eelf32ltsmipn32_fbsd.c \
eelf32m32c.c \
eelf32mb_linux.c \
eelf32mcore.c \
@@ -262,7 +241,6 @@ ALL_EMULATION_SOURCES = \
eelf32metag.c \
eelf32microblazeel.c \
eelf32microblaze.c \
- eelf32mipswindiss.c \
eelf32moxie.c \
eelf32mt.c \
eelf32openrisc.c \
@@ -490,6 +468,28 @@ ALL_64_EMULATION_SOURCES = \
eaarch64linuxb.c \
eelf32_x86_64.c \
eelf32_x86_64_nacl.c \
+ eelf32b4300.c \
+ eelf32bmip.c \
+ eelf32bmipn32.c \
+ eelf32bsmip.c \
+ eelf32btsmip.c \
+ eelf32btsmip_fbsd.c \
+ eelf32btsmipn32.c \
+ eelf32btsmipn32_fbsd.c \
+ eelf32ebmip.c \
+ eelf32ebmipvxworks.c \
+ eelf32elmip.c \
+ eelf32elmipvxworks.c \
+ eelf32l4300.c \
+ eelf32lmip.c \
+ eelf32lr5900.c \
+ eelf32lr5900n32.c \
+ eelf32lsmip.c \
+ eelf32ltsmip.c \
+ eelf32ltsmip_fbsd.c \
+ eelf32ltsmipn32.c \
+ eelf32ltsmipn32_fbsd.c \
+ eelf32mipswindiss.c \
eelf64_aix.c \
eelf64_ia64.c \
eelf64_ia64_fbsd.c \