summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-24 05:57:44 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-24 05:57:44 +0000
commit523d92541c04d74fa5132fe8f0aa7bb8a1773a59 (patch)
tree62c1f6b0e8ffc63cf7963117edfc0172351b17fb /ld/Makefile.am
parentdd0d9ec842d77c9cf0e7ae0d5013c4e36bbee892 (diff)
downloadbinutils-redhat-523d92541c04d74fa5132fe8f0aa7bb8a1773a59.tar.gz
dependency tracking fixes in ld
ld/: * Makefile.am (ldmain.o, ldfile.o): Fix typos in non-fastdep rules. (eelf32_spu.o): Add dependency tracking. * Makefile.in: Regenerate.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index bc4915c487..146901569e 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -523,7 +523,7 @@ if am__fastdepCC
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
- source='deffilep.c' object='$@' libtool=no @AMDEPBACKSLASH@
+ source='ldmain.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
$(COMPILE) -c -DDEFAULT_EMULATION='"$(EMUL)"' \
@@ -540,7 +540,7 @@ if am__fastdepCC
mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
else
if AMDEP
- source='deffilep.c' object='$@' libtool=no @AMDEPBACKSLASH@
+ source='ldfile.c' object='$@' libtool=no @AMDEPBACKSLASH@
DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
endif
$(COMPILE) -c -DSCRIPTDIR='"$(scriptdir)"' -DBINDIR='"$(bindir)"' \
@@ -549,8 +549,18 @@ endif
endif
eelf32_spu.o: eelf32_spu.c
+if am__fastdepCC
+ $(COMPILE) -MT $@ -MD -MP -MF $(DEPDIR)/$*.Tpo -c -o $@ \
+ -DEMBEDSPU="\"`echo embedspu | sed '$(transform)'`\"" eelf32_spu.c
+ mv -f $(DEPDIR)/$*.Tpo $(DEPDIR)/$*.Po
+else
+if AMDEP
+ source='eelf32_spu.c' object='$@' libtool=no @AMDEPBACKSLASH@
+ DEPDIR=$(DEPDIR) $(CCDEPMODE) $(depcomp) @AMDEPBACKSLASH@
+endif
$(COMPILE) -c -DEMBEDSPU="\"`echo embedspu | sed '$(transform)'`\"" \
eelf32_spu.c
+endif
ldemul-list.h: Makefile
(echo "/* This file is automatically generated. DO NOT EDIT! */";\