summaryrefslogtreecommitdiff
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2007-06-18 10:58:07 +0000
committerAlan Modra <amodra@bigpond.net.au>2007-06-18 10:58:07 +0000
commitc22879472d827ddcf241e2f05edf69682b99c050 (patch)
tree17d588f786b0167931e9ba3f8d05332ee6b8d157 /ld/Makefile.am
parent0740026909028b1811d7bf0cf77d5e6b79a42d20 (diff)
downloadbinutils-redhat-c22879472d827ddcf241e2f05edf69682b99c050.tar.gz
* Makefile.am: Add eelf32_spu.o rule.
* Makefile.in: Regenerate. * emultempl/spuelf.em: Revert last change. Instead use EMBEDSPU defined in Makefile for embedspu name.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index b7a4b80e7b..c30bd28758 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -468,6 +468,10 @@ ldmain.o: ldmain.c config.status
-DTARGET='"@target@"' @TARGET_SYSTEM_ROOT_DEFINE@ \
$(srcdir)/ldmain.c
+eelf32_spu.o: eelf32_spu.c
+ $(COMPILE) -c -DEMBEDSPU="\"`echo embedspu | sed '$(transform)'`\"" \
+ eelf32_spu.c
+
ldemul-list.h: Makefile
(echo "/* This file is automatically generated. DO NOT EDIT! */";\
for f in `echo " " ${EMULATION_OFILES} "" \