summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorRichard Sandiford <rsandifo@nildram.co.uk>2007-05-16 07:19:46 +0000
committerRichard Sandiford <rsandifo@nildram.co.uk>2007-05-16 07:19:46 +0000
commit559f560b628b24cfed0a0ada38b134cf3f8fc80d (patch)
tree90ca7758fde30070e90bcd124aa18ec194353eaa /ld/configure.in
parentc0cebdc28526b21e56d8867bff13cbb6821db133 (diff)
downloadbinutils-redhat-559f560b628b24cfed0a0ada38b134cf3f8fc80d.tar.gz
ld/
* configure.in: Allow sysroots to be relocated under $prefix as well as $exec_prefix. * configure: Regenerate.
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in15
1 files changed, 9 insertions, 6 deletions
diff --git a/ld/configure.in b/ld/configure.in
index 3fd64c068f..0589578a74 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -41,17 +41,20 @@ AC_ARG_WITH(sysroot,
TARGET_SYSTEM_ROOT_DEFINE='-DTARGET_SYSTEM_ROOT=\"$(TARGET_SYSTEM_ROOT)\"'
use_sysroot=yes
+ if test "x$prefix" = xNONE; then
+ test_prefix=/usr/local
+ else
+ test_prefix=$prefix
+ fi
if test "x$exec_prefix" = xNONE; then
- if test "x$prefix" = xNONE; then
- test_prefix=/usr/local
- else
- test_prefix=$prefix
- fi
+ test_exec_prefix=$test_prefix
else
- test_prefix=$exec_prefix
+ test_exec_prefix=$exec_prefix
fi
case ${TARGET_SYSTEM_ROOT} in
"${test_prefix}"|"${test_prefix}/"*|\
+ "${test_exec_prefix}"|"${test_exec_prefix}/"*|\
+ '${prefix}'|'${prefix}/'*|\
'${exec_prefix}'|'${exec_prefix}/'*)
t="$TARGET_SYSTEM_ROOT_DEFINE -DTARGET_SYSTEM_ROOT_RELOCATABLE"
TARGET_SYSTEM_ROOT_DEFINE="$t"