summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorCarlos O'Donell <carlos@codesourcery.com>2006-04-06 21:49:35 +0000
committerCarlos O'Donell <carlos@codesourcery.com>2006-04-06 21:49:35 +0000
commit8d074d15654fb02f5fd9e8830ebb26fffd4b4fe5 (patch)
treeab6db93ce0de40c0813f9173d354534bed30fb4e /ld/configure.in
parentb1430f29c1c1238e240387fb7ddec6e850d88a57 (diff)
downloadbinutils-redhat-8d074d15654fb02f5fd9e8830ebb26fffd4b4fe5.tar.gz
2006-04-06 Carlos O'Donell <carlos@codesourcery.com>
* Makefile.tpl: Add install-html target. * Makefile.def: Add install-html target. * Makefile.in: Regenerate. * configure.in: Add --with-datarootdir, --with-docdir, and --with-htmldir options. * configure: Regenerate. bfd/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * po/Make-in: Add install-html target. * Makefile.am: Rename docdir to bfddocdir. Add datarootdir, docdir htmldir. Add install-html and install-html-recursive targets. * Makefile.in: Regenerate. * configure.in: AC_SUBST for datarootdir, docdir and htmldir. * configure: Regenerate. bfd/doc/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * Makefile.am: Add install-html and install-html-am targets. Define datarootdir, docdir and htmldir. * Makefile.in: Regenerate. binutils/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * po/Make-in: Add install-html target. * Makefile.am: Add install-html and install-html-recursive targets. * Makefile.in: Regenerate. * configure.in: AC_SUBST datarootdir, docdir and htmldir. * configure: Regenerate. * doc/Makefile.am: Add install-html and install-html-am targets. * doc/Makefile.in: Regenerate. etc/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * Makefile.in: Add install-html target. Add htmldir, docdir and datarootdir. * configure.texi: Document install-html target. * configure.in: AC_SUBST datarootdir, docdir, htmldir. * configure: Regenerate. gas/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * po/Make-in: Add install-html target. * Makefile.am: Add install-html and install-html-recursive targets. * Makefile.in: Regenerate. * configure.in: AC_SUBST datarootdir, docdir, htmldir. * configure: Regenerate. * doc/Makefile.am: Add install-html and install-html-am targets. * doc/Makefile.in: Regenerate. gprof/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * po/Make-in: Add install-html target. * Makefile.am: Add install-html, install-html-am and install-html-recursive targets. * Makefile.in: Regenerate. * configure.in: AC_SUBST datarootdir, docdir, htmldir. * configure: Regenerate. intl/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * intl/Makefile.in: Add html info and dvi and install-html to .PHONY Add install-html target. ld/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * Makefile.am: Add install-html, install-html-am, and install-html-recursive targets. * Makefile.in: Regenerate. * configure.in: AC_SUBST datarootdir, docdir, htmldir. * configure: Regenerate. * po/Make-in: Add install-html target. opcodes/ 2006-04-06 Carlos O'Donell <carlos@codesourcery.com> * Makefile.am: Add install-html target. * Makefile.in: Regenerate.
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/ld/configure.in b/ld/configure.in
index 41b641433f..1c91d59d51 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -253,5 +253,10 @@ if test x${EXTRA_SHLIB_EXTENSION} != x ; then
[Additional extension a shared object might have.])
fi
+dnl Required by html and install-html
+AC_SUBST(datarootdir)
+AC_SUBST(docdir)
+AC_SUBST(htmldir)
+
AC_OUTPUT(Makefile po/Makefile.in:po/Make-in,
[sed -e '/POTFILES =/r po/POTFILES' po/Makefile.in > po/Makefile])