summaryrefslogtreecommitdiff
path: root/ld/configure.in
diff options
context:
space:
mode:
authorH.J. Lu <hjl@lucon.org>2006-05-25 01:03:09 +0000
committerH.J. Lu <hjl@lucon.org>2006-05-25 01:03:09 +0000
commitd1f2db2b2c421f06f4d1d0dda7cebbe34e1e78ec (patch)
tree81c962548e3739c7a8d4c37ac938b0470f31bd2f /ld/configure.in
parent8a314c7f8ce60dc4a790d85425b73b9cf937f47f (diff)
downloadbinutils-redhat-d1f2db2b2c421f06f4d1d0dda7cebbe34e1e78ec.tar.gz
bfd/
2006-05-24 H.J. Lu <hongjiu.lu@intel.com> PR ld/1485 * config.bfd: Set want64 to true if 64bit bfd is used. (sh-*-linux*): Use targ64_selvecs for 64bit targets. (sh*l*-*-netbsdelf*): Likewise. (sh-*-netbsdelf*): Likewise. (shl*-*-elf*): Likewise. (sh[1234]l*-*-elf*): Likewise. (sh3el*-*-elf*): Likewise. (shl*-*-kaos*): Likewise. (sh-*-elf*): Likewise. (sh[1234]*-elf*): Likewise. (sh-*-rtems*): Likewise. (sh-*-kaos*): Likewise. ld/ 2006-05-24 H.J. Lu <hongjiu.lu@intel.com> PR ld/1485 * configure.in: Use ${srcdir}/../bfd/config.bfd to check 64bit bfd. Support 64bit host for --enable-targets=all. * configure: Regenerated.
Diffstat (limited to 'ld/configure.in')
-rw-r--r--ld/configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/ld/configure.in b/ld/configure.in
index e020288c00..0f3c58d701 100644
--- a/ld/configure.in
+++ b/ld/configure.in
@@ -169,6 +169,10 @@ do
EMUL=$targ_emul
fi
+ if test x${want64} = xfalse; then
+ . ${srcdir}/../bfd/config.bfd
+ fi
+
for i in $targ_emul $targ_extra_emuls $targ_extra_libpath; do
case " $all_emuls " in
*" e${i}.o "*) ;;
@@ -210,10 +214,13 @@ AC_SUBST(EMUL)
TDIRS=tdirs
AC_SUBST_FILE(TDIRS)
-dnl FIXME: We will build a 64 bit BFD for a 64 bit host or a 64 bit
-dnl target, and in those cases we should also build the 64 bit
-dnl emulations.
if test x${all_targets} = xtrue; then
+ if test x${want64} = xfalse; then
+ AC_CHECK_SIZEOF(long)
+ if test "x${ac_cv_sizeof_long}" = "x8"; then
+ want64=true
+ fi
+ fi
if test x${want64} = xtrue; then
EMULATION_OFILES='$(ALL_EMULATIONS) $(ALL_64_EMULATIONS)'
else