summaryrefslogtreecommitdiff
path: root/libiberty/configure.ac
diff options
context:
space:
mode:
authorDJ Delorie <dj@delorie.com>2004-01-22 19:34:11 +0000
committerDJ Delorie <dj@delorie.com>2004-01-22 19:34:11 +0000
commitaf0651811dc3617ca4d1f2b7b02798faf9253846 (patch)
tree4e98e0e765c27c8204432bae8669266d0d61feea /libiberty/configure.ac
parent73546a3ba36fdab252731bdf8988b91e8eed65d0 (diff)
downloadbinutils-redhat-af0651811dc3617ca4d1f2b7b02798faf9253846.tar.gz
merge from gcc
Diffstat (limited to 'libiberty/configure.ac')
-rw-r--r--libiberty/configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/libiberty/configure.ac b/libiberty/configure.ac
index eb8a99daa0..3e379cc85a 100644
--- a/libiberty/configure.ac
+++ b/libiberty/configure.ac
@@ -477,11 +477,11 @@ fi
# Figure out which version of pexecute to use.
case "${host}" in
- *-*-mingw* | *-*-winnt*) pexecute=pex-win32.o ;;
- *-*-msdosdjgpp*) pexecute=pex-djgpp.o ;;
- *-*-msdos*) pexecute=pex-msdos.o ;;
- *-*-os2-emx*) pexecute=pex-os2.o ;;
- *) pexecute=pex-unix.o ;;
+ *-*-mingw* | *-*-winnt*) pexecute=./pex-win32.o ;;
+ *-*-msdosdjgpp*) pexecute=./pex-djgpp.o ;;
+ *-*-msdos*) pexecute=./pex-msdos.o ;;
+ *-*-os2-emx*) pexecute=./pex-os2.o ;;
+ *) pexecute=./pex-unix.o ;;
esac
AC_SUBST(pexecute)
@@ -496,6 +496,15 @@ else
fi
AC_SUBST(INSTALL_DEST)
+L=""
+for l in x $LIBOBJS; do
+ case $l in
+ x) ;;
+ *) L="$L ./$l" ;;
+ esac
+done
+LIBOBJS="$L"
+
# We need multilib support, but only if configuring for the target.
AC_OUTPUT(Makefile testsuite/Makefile,
[test -z "$CONFIG_HEADERS" || echo timestamp > stamp-h