summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorDoug Evans <dje@sebabeach.org>2002-12-20 01:40:08 +0000
committerDoug Evans <dje@sebabeach.org>2002-12-20 01:40:08 +0000
commit30d44b2f77a2a3021a5cd04f43d37981899e4da5 (patch)
treef9a2ab4cb43d12b06c8f4a2104594f320c930e89 /opcodes/Makefile.am
parent7433aec362886036dfaa720e0c372bdfcf2a42b0 (diff)
downloadbinutils-redhat-30d44b2f77a2a3021a5cd04f43d37981899e4da5.tar.gz
* Makefile.am (CGEN_CPUS): New variable.
(run-cgen-all): New rule. * Makefile.in: Regenerate.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 6bdfa36ca1..ba0072681c 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -342,6 +342,8 @@ CGENDEPS = \
$(CGENDIR)/opc-opinst.scm \
cgen-asm.in cgen-dis.in cgen-ibld.in
+CGEN_CPUS = fr30 frv ip2k m32r openrisc xstormy16
+
if CGEN_MAINT
IP2K_DEPS = stamp-ip2k
M32R_DEPS = stamp-m32r
@@ -365,6 +367,14 @@ run-cgen:
touch stamp-${prefix}
.PHONY: run-cgen
+# Maintainer utility rule to regenerate all cgen files.
+run-cgen-all:
+ for c in $(CGEN_CPUS) ; \
+ do \
+ $(MAKE) stamp-$$c || exit 1 ; \
+ done
+.PHONY: run-cgen-all
+
# For now, require developers to configure with --enable-cgen-maint.
$(srcdir)/ip2k-desc.h $(srcdir)/ip2k-desc.c $(srcdir)/ip2k-opc.h $(srcdir)/ip2k-opc.c $(srcdir)/ip2k-ibld.c $(srcdir)/ip2k-asm.c $(srcdir)/ip2k-dis.c: $(IP2K_DEPS)
@true