summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorNick Clifton <nickc@redhat.com>2013-06-21 15:01:56 +0000
committerNick Clifton <nickc@redhat.com>2013-06-21 15:01:56 +0000
commit37cb790ef67a7467afd51e01421fade4730e2296 (patch)
tree8f7dab2abfdfa440ba49e78ace5f8c67488d0c9b /opcodes/Makefile.am
parent49debc8e087353ab82718b7cc15b0a3e3b72c320 (diff)
downloadbinutils-redhat-37cb790ef67a7467afd51e01421fade4730e2296.tar.gz
* msp430-decode.opc: New.
* msp430-decode.c: New/generated. * Makefile.am (TARGET_LIBOPCODES_CFILES): Add msp430-decode.c. (MAINTAINER_CLEANFILES): Likewise. Add rule to build msp430-decode.c frommsp430decode.opc using the opc2c program. * Makefile.in: Regenerate. * configure.in: Add msp430-decode.lo to msp430 architecture files. * configure: Regenerate. * msp430-decode.h: New.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 827c96ecc6..98d53a8cf7 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -199,6 +199,7 @@ TARGET_LIBOPCODES_CFILES = \
mmix-opc.c \
moxie-dis.c \
moxie-opc.c \
+ msp430-decode.c \
msp430-dis.c \
mt-asm.c \
mt-desc.c \
@@ -516,6 +517,7 @@ MOSTLYCLEANFILES = aarch64-gen$(EXEEXT_FOR_BUILD) i386-gen$(EXEEXT_FOR_BUILD) \
MAINTAINERCLEANFILES = $(srcdir)/aarch64-asm-2.c $(srcdir)/aarch64-dis-2.c \
$(srcdir)/aarch64-opc-2.c $(srcdir)/i386-tbl.h $(srcdir)/i386-init.h \
$(srcdir)/ia64-asmtab.c $(srcdir)/z8k-opc.h \
+ $(srcdir)/msp430-decode.c \
$(srcdir)/rl78-decode.c \
$(srcdir)/rx-decode.c
@@ -569,6 +571,9 @@ $(srcdir)/ia64-asmtab.c: @MAINT@ $(ia64_asmtab_deps)
ia64-opc.lo: $(srcdir)/ia64-asmtab.c
+$(srcdir)/msp430-decode.c: @MAINT@ $(srcdir)/msp430-decode.opc opc2c$(EXEEXT_FOR_BUILD)
+ ./opc2c$(EXEEXT_FOR_BUILD) $(srcdir)/msp430-decode.opc > $(srcdir)/msp430-decode.c
+
$(srcdir)/rl78-decode.c: @MAINT@ $(srcdir)/rl78-decode.opc opc2c$(EXEEXT_FOR_BUILD)
./opc2c$(EXEEXT_FOR_BUILD) $(srcdir)/rl78-decode.opc > $(srcdir)/rl78-decode.c