summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorDave Brolley <brolley@redhat.com>2003-08-29 19:14:54 +0000
committerDave Brolley <brolley@redhat.com>2003-08-29 19:14:54 +0000
commit5a76bcc820888710c8f420c5ee9d0a855f65150a (patch)
tree7dc424dc007e926740b42fb5ac310ef0963b681e /opcodes/Makefile.am
parent49e2ebe7d68d8dc8015ca4d9c66a6e19e7be6ce3 (diff)
downloadbinutils-redhat-5a76bcc820888710c8f420c5ee9d0a855f65150a.tar.gz
2003-08-29 Dave Brolley <brolley@redhat.com>
* Makefile.am (stamp-frv): Copy frv.cpu and frv.opc from $(srcdir)/../cpu temporarily when regenerating source files. * Makefile.in: Regenerated.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index ae03afc6d6..0bb7fd2004 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -409,8 +409,14 @@ stamp-fr30: $(CGENDEPS) $(CPUDIR)/fr30.cpu $(CPUDIR)/fr30.opc
$(srcdir)/frv-desc.h $(srcdir)/frv-desc.c $(srcdir)/frv-opc.h $(srcdir)/frv-opc.c $(srcdir)/frv-ibld.c $(srcdir)/frv-asm.c $(srcdir)/frv-dis.c: $(FRV_DEPS)
@true
-stamp-frv: $(CGENDEPS) $(CPUDIR)/frv.cpu $(CPUDIR)/frv.opc
+# .cpu and .opc files for frv are kept in a different directory, but cgen has no switch to specify that location, so
+# copy those file to the regular place.
+stamp-frv: $(CGENDEPS) $(srcdir)/../cpu/frv.cpu $(srcdir)/../cpu/frv.opc
+ cp -fp $(srcdir)/../cpu/frv.cpu $(CPUDIR)/frv.cpu
+ cp -fp $(srcdir)/../cpu/frv.opc $(CPUDIR)/frv.opc
$(MAKE) run-cgen arch=frv prefix=frv options= extrafiles=
+ rm -f $(CPUDIR)/frv.cpu
+ rm -f $(CPUDIR)/frv.opc
$(srcdir)/openrisc-desc.h $(srcdir)/openrisc-desc.c $(srcdir)/openrisc-opc.h $(srcdir)/openrisc-opc.c $(srcdir)/openrisc-ibld.c $(srcdir)/openrisc-asm.c $(srcdir)/openrisc-dis.c: $(OPENRISC_DEPS)
@true