summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-27 05:24:43 +0000
committerRalf Wildenhues <Ralf.Wildenhues@gmx.de>2009-08-27 05:24:43 +0000
commitaf9066608914047b60c7bf9a0e7b5d3aacddba55 (patch)
treefb941c619d2ac41aa9a5b87ac4864cc9968b8399 /opcodes/Makefile.am
parent5e4503e68e13eca6b2488c8914e106bb30c3c45d (diff)
downloadbinutils-redhat-af9066608914047b60c7bf9a0e7b5d3aacddba55.tar.gz
Do not create $(bfdlibdir) and $(bfdincludedir) if !INSTALL_LIBBFD.
opcodes/: * Makefile.am (bfdlibdir, bfdincludedir): Move definition ... [INSTALL_LIBBFD]: ... here, ... [INSTALL_LIBBFD]: ... and empty overrides here. [!INSTALL_LIBBFD]: (rpath_bfdlibdir): New variable. [!INSTALL_LIBBFD] (libbfd_la_LDFLAGS): Use it. * Makefile.in: Regenerate. * configure: Regenerate. bfd/: * acinclude.m4 (AM_INSTALL_LIBBFD): Call AM_SUBST_NOTMAKE for bfdlibdir and bfdincludedir. * Makefile.am (bfdlibdir, bfdincludedir): Move definition ... [INSTALL_LIBBFD]: ... here, ... [INSTALL_LIBBFD]: ... and empty overrides here. [!INSTALL_LIBBFD]: (rpath_bfdlibdir): New variable. [!INSTALL_LIBBFD] (libbfd_la_LDFLAGS): Use it. * Makefile.in: Regenerate. * configure: Regenerate. bfd/doc/: * Makefile.in: Regenerate.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 465ea05b79..4f9a3909fe 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -17,16 +17,19 @@ COMPILE_FOR_BUILD = $(CC_FOR_BUILD) $(INCLUDES) $(AM_CPPFLAGS) \
$(BUILD_CPPFLAGS) $(BUILD_CFLAGS)
LINK_FOR_BUILD = $(CC_FOR_BUILD) $(BUILD_CFLAGS) $(BUILD_LDFLAGS) -o $@
-bfdlibdir = @bfdlibdir@
-bfdincludedir = @bfdincludedir@
-
libopcodes_la_LDFLAGS =
if INSTALL_LIBBFD
+bfdlibdir = @bfdlibdir@
+bfdincludedir = @bfdincludedir@
bfdlib_LTLIBRARIES = libopcodes.la
bfdinclude_DATA = $(INCDIR)/dis-asm.h
else
+# Empty these so that the respective installation directories will not be created.
+bfdlibdir =
+bfdincludedir =
+rpath_bfdlibdir = @bfdlibdir@
noinst_LTLIBRARIES = libopcodes.la
-libopcodes_la_LDFLAGS += -rpath $(bfdlibdir)
+libopcodes_la_LDFLAGS += -rpath $(rpath_bfdlibdir)
endif
# This is where bfd.h lives.