summaryrefslogtreecommitdiff
path: root/opcodes/configure.in
diff options
context:
space:
mode:
authorAlan Modra <amodra@bigpond.net.au>2009-09-07 10:54:25 +0000
committerAlan Modra <amodra@bigpond.net.au>2009-09-07 10:54:25 +0000
commit3ea6f5ae97a40f4d7b99560185fac8e7c45427ee (patch)
tree3bd72a320a79396a4ac63e172ad2433b209fcf81 /opcodes/configure.in
parenta927089f8c72abe7c76c32d862aa1407642b99f1 (diff)
downloadbinutils-redhat-3ea6f5ae97a40f4d7b99560185fac8e7c45427ee.tar.gz
* configure.in (BUILD_LIBS, BUILD_LIB_DEPS): Define and subst.
* configure: Regenerate. * Makefile.am (LIBIBERTY, BUILD_LIBIBERTY, BUILD_LIBINTL): Delete. (BUILD_LIBS, BUILD_LIB_DEPS): Define. Use.. (i386-gen, ia64-gen, z8kgen): ..here. * Makefile.in: Regenerate.
Diffstat (limited to 'opcodes/configure.in')
-rw-r--r--opcodes/configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/opcodes/configure.in b/opcodes/configure.in
index c634470777..75414d799a 100644
--- a/opcodes/configure.in
+++ b/opcodes/configure.in
@@ -101,6 +101,22 @@ AC_CACHE_CHECK(linker --as-needed support, bfd_cv_ld_as_needed,
LT_LIB_M
+#Libs for generator progs
+if test "x$cross_compiling" = "xno"; then
+ BUILD_LIBS=../libiberty/libiberty.a
+ BUILD_LIB_DEPS=$BUILD_LIBS
+else
+ # if cross-compiling, assume that the system provides -liberty
+ # and that the version is compatible with new headers.
+ BUILD_LIBS=-liberty
+ BUILD_LIB_DEPS=
+fi
+BUILD_LIBS="$BUILD_LIBS $LIBINTL"
+BUILD_LIB_DEPS="$BUILD_LIB_DEPS $LIBINTL_DEP"
+
+AC_SUBST(BUILD_LIBS)
+AC_SUBST(BUILD_LIB_DEPS)
+
# Horrible hacks to build DLLs on Windows and a shared library elsewhere.
SHARED_LDFLAGS=
SHARED_LIBADD=