summaryrefslogtreecommitdiff
path: root/gas/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'gas/configure.in')
-rw-r--r--gas/configure.in29
1 files changed, 4 insertions, 25 deletions
diff --git a/gas/configure.in b/gas/configure.in
index 37f6d5f5e7..121fcfcba9 100644
--- a/gas/configure.in
+++ b/gas/configure.in
@@ -164,12 +164,6 @@ for this_target in $target $canon_targets ; do
microblaze*)
;;
- mips-sony-bsd*)
- ;;
- mips-*-bsd*)
- AC_MSG_ERROR(Unknown vendor for mips-bsd configuration.)
- ;;
-
changequote(,)dnl
ppc-*-aix[5-9].*)
changequote([,])dnl
@@ -252,7 +246,6 @@ changequote([,])dnl
esac
# See whether it's appropriate to set E_MIPS_ABI_O32 for o32
# binaries. It's a GNU extension that some OSes don't understand.
- # The value only matters on ELF targets.
case ${target} in
*-*-irix*)
use_e_mips_abi_o32=0
@@ -430,22 +423,10 @@ changequote([,])dnl
# From target name and format, produce a list of supported emulations.
case ${generic_target}-${fmt} in
- mips-*-irix5*-*) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
- mips*-*-linux*-* | mips*-*-freebsd* | mips*-*-kfreebsd*-gnu)
- case "$endian" in
- big) emulation="mipsbelf mipslelf mipself" ;;
- *) emulation="mipslelf mipsbelf mipself" ;;
- esac ;;
- mips-*-lnews*-ecoff) ;;
- mips-*-*-ecoff) case "$endian" in
- big) emulation="mipsbecoff mipslecoff mipsecoff" ;;
- *) emulation="mipslecoff mipsbecoff mipsecoff" ;;
- esac ;;
- mips-*-*-elf) case "$endian" in
+ mips-*-*-*) case "$endian" in
big) emulation="mipsbelf mipslelf mipself" ;;
*) emulation="mipslelf mipsbelf mipself" ;;
esac ;;
- mips-*-sysv4*MP*-*) emulation="mipsbelf mipslelf mipself mipsbecoff mipslecoff mipsecoff" ;;
# i386-pc-pe-coff != i386-pc-coff.
i386-*-pe-coff) ;;
# Uncommenting the next line will turn on support for i386 AOUT
@@ -558,7 +539,7 @@ esac
#
# And then there's "--enable-targets=all"....
#
-# For now, just always do it for MIPS ELF or ECOFF configurations. Sigh.
+# For now, just always do it for MIPS ELF configurations. Sigh.
formats="${obj_format}"
emfiles=""
@@ -569,8 +550,6 @@ for em in . $emulations ; do
.) continue ;;
mipsbelf | mipslelf | mipself)
fmt=elf file=mipself ;;
- mipsbecoff | mipslecoff | mipsecoff)
- fmt=ecoff file=mipsecoff ;;
*coff)
fmt=coff file=$em ;;
*aout)
@@ -601,11 +580,11 @@ if test `set . $formats ; shift ; echo $#` -gt 1 ; then
fi
if test `set . $emfiles ; shift ; echo $#` -gt 0 ; then
DEFAULT_EMULATION=`set . $emulations ; echo $2`
- # e-mips* has more than one emulation per file, e-i386* has just one at the
+ # e-mipself has more than one emulation per file, e-i386* has just one at the
# moment. If only one emulation is specified, then don't define
# USE_EMULATIONS or include any of the e-files as they will only be bloat.
case "${obj_format}${emfiles}" in
- multi* | *mips*)
+ multi* | *mipself*)
extra_objects="$extra_objects $emfiles"
AC_DEFINE(USE_EMULATIONS, 1, [Use emulation support?]) ;;
esac