summaryrefslogtreecommitdiff
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 1583109c74..a709193a6a 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -371,6 +371,9 @@ s390-mkopc: s390-mkopc.c
s390-opc.tab: s390-mkopc s390-opc.txt
./s390-mkopc < $(srcdir)/s390-opc.txt > s390-opc.tab
+sh-dis.lo: sh-dis.c
+ $(LIBTOOL) --mode=compile $(COMPILE) -c @archdefs@ $<
+
Makefile: $(BFDDIR)/configure.in
# This dependency stuff is copied from BFD.
@@ -632,7 +635,6 @@ s390-dis.lo: s390-dis.c $(INCDIR)/ansidecl.h sysdep.h \
$(INCDIR)/opcode/s390.h
sh-dis.lo: sh-dis.c sysdep.h config.h $(INCDIR)/ansidecl.h \
sh-opc.h $(INCDIR)/dis-asm.h $(BFD_H) $(INCDIR)/symcat.h
- $(LIBTOOL) --mode=compile $(COMPILE) -c @archdefs@ $<
sh64-dis.lo: sh64-dis.c $(INCDIR)/dis-asm.h $(BFD_H) \
$(INCDIR)/ansidecl.h $(INCDIR)/symcat.h sysdep.h config.h \
sh64-opc.h $(INCDIR)/libiberty.h $(BFDDIR)/elf-bfd.h \