summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJoel E. Denny <jdenny@clemson.edu>2009-08-04 18:06:20 -0400
committerJoel E. Denny <jdenny@clemson.edu>2009-08-04 21:27:06 -0400
commit269e222e24b03ccc4ab7881d960750ddeb131b05 (patch)
tree41a6a9ec136a78411a65e23974e9fb1417150112 /Makefile.am
parent35905f2b4583efaa3d2dd52ec7bb834e6a571cc8 (diff)
downloadbison-269e222e24b03ccc4ab7881d960750ddeb131b05.tar.gz
maint: automate b4_copyright updates.
* Makefile.am (update-b4-copyright): New target rule. * build-aux/local.mk (EXTRA_DIST): Add update-b4-copyright. * build-aux/update-b4-copyright: New. * data/yacc.c: Remove stray characters around b4_copyright invocations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 68d6d8b6..1bd44016 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,3 +60,10 @@ $(top_srcdir)/.version: configure
echo $(VERSION) > $@-t && mv $@-t $@
dist-hook:
echo $(VERSION) > $(distdir)/.tarball-version
+
+.PHONY: update-b4-copyright
+update-b4-copyright:
+ find data -type f \
+ | grep -v -E '^data/bison.m4$$' \
+ | xargs $(build_aux)/$@
+ @echo 'warning: src/parse-gram.[hc] may need to be regenerated.'