summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-09-06 18:06:58 +0200
committerAkim Demaille <akim.demaille@gmail.com>2018-09-06 21:28:24 +0200
commit2c29a70819b79e343fa292c549975bdc7ae720b8 (patch)
tree89d8bf77f15fe2c5ff997417d33f72b0fe390c72 /configure.ac
parentcf31256f9a4fc906b3e195703e4c98aa2411635a (diff)
downloadbison-2c29a70819b79e343fa292c549975bdc7ae720b8.tar.gz
tests: fix maintainer-check-g++ make recipe
Clang++ issues warnings when it's used to compile C. This make target is precisely checking whether we can do that. * configure.ac (NO_DEPRECATED_CXXFLAGS): New. * tests/atlocal.in: Use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a9dcb00..cc601d3c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -154,6 +154,8 @@ if test "$enable_gcc_warnings" = yes; then
gl_WARN_ADD([-Wno-zero-as-null-pointer-constant], [FLEX_SCANNER_CXXFLAGS])
CXXFLAGS=$save_CXXFLAGS
gl_WARN_ADD([-fno-exceptions], [CXXFLAGS_NO_EXCEPTIONS])
+ # Clang++ deprecates compiling C.
+ gl_WARN_ADD([-Wno-deprecated], [WNO_DEPRECATED_CXXFLAGS])
AC_LANG_POP([C++])
fi