summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-09-18 07:05:01 +0200
committerAkim Demaille <akim.demaille@gmail.com>2018-09-19 06:02:41 +0200
commit49dc1b5bf1bc170e9bb1b2aec30272fd74c3be4c (patch)
treef37fff38e88332673578d23a3a89fcea207cc4b1 /configure.ac
parentf475105c2fd039e3fc5110e75c27e39a6a835bcb (diff)
downloadbison-49dc1b5bf1bc170e9bb1b2aec30272fd74c3be4c.tar.gz
build: don't accept a broken standard lib for C++
On the CI, we had failures such as: ./c++.at:401: $PREPARSER ./list stderr: ./list: error while loading shared libraries: libc++.so.1: cannot open shared object file: No such file or directory because we accepted `-std=c++ -stdlib=libc++` although libc++ is not installed on the machine. * m4/ax_check_compile_flag.m4 (AX_CHECK_COMPILE_FLAG): Rewrite as... * m4/bison-check-compile-flag.m4 (BISON_CHECK_COMPILE_FLAG): this, so that we use AC_LINK_IFELSE to check the compiler (and its std lib) instead of AC_COMPILE_IFELSE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2a4269cc..232ee8d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,7 +21,7 @@
# better to avoid a typo in the 'configure --help' entry for the YACC
# environment variable.
AC_PREREQ([2.68])
-m4_pattern_forbid([^_?(gl_[A-Z]|BISON_)])
+m4_pattern_forbid([^_?(gl_[A-Z]|AX_|BISON_)])
m4_pattern_allow([^BISON_USE_NLS$])
AC_INIT([GNU Bison],