summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-09-23 09:42:50 +0200
committerAkim Demaille <akim.demaille@gmail.com>2018-09-23 11:50:58 +0200
commit5d0764d23b84a2fdb5c3f1e83668ee00389443fa (patch)
tree7d5dddba2378e0031853e45f0b1a482b96cd13f0 /configure.ac
parent41ded5828664e7cbad659ef3d8475fca9cb11035 (diff)
downloadbison-5d0764d23b84a2fdb5c3f1e83668ee00389443fa.tar.gz
build: rename and simplify the -std checks for C++
Too much code duplication. * m4/bison-cxx-std.m4: s/BISON_CXX_COMPILE_STDCXX/BISON_CXXSTD/. (BISON_CXXSTD): New. * configure.ac: Use it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0540a50a..28639408 100644
--- a/configure.ac
+++ b/configure.ac
@@ -73,12 +73,12 @@ AC_CACHE_CHECK([whether pragma GCC diagnostic push works],
AC_LANG_PUSH([C++])
gl_WARN_ADD([-fno-exceptions], [NO_EXCEPTIONS_CXXFLAGS])
-BISON_CXX_COMPILE_STDCXX_98
-BISON_CXX_COMPILE_STDCXX_03
-BISON_CXX_COMPILE_STDCXX_11
-BISON_CXX_COMPILE_STDCXX_14
-BISON_CXX_COMPILE_STDCXX_17
-BISON_CXX_COMPILE_STDCXX_2A
+BISON_CXXSTD([98])
+BISON_CXXSTD([03])
+BISON_CXXSTD([11])
+BISON_CXXSTD([14])
+BISON_CXXSTD([17])
+BISON_CXXSTD([2a])
AM_CONDITIONAL([ENABLE_CXX11], [test x"$CXX11_CXXFLAGS" != x])
AC_LANG_POP([C++])