summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim@lrde.epita.fr>2013-01-30 15:52:34 +0100
committerAkim Demaille <akim@lrde.epita.fr>2013-01-30 16:10:12 +0100
commitdf1ca1b0de2d99879f7b41e64d8bf285f163b1aa (patch)
treea1136daf08153b6b79d458bd947ac2fad8659058 /configure.ac
parent1217688141e33e03112330a24ff352d9263ef7bc (diff)
downloadbison-df1ca1b0de2d99879f7b41e64d8bf285f163b1aa.tar.gz
build: avoid clang's colored diagnostics in the test suite
The syncline tests, which try to recognize compiler diagnostics, are confused by escapes for colors. * configure.ac (warn_tests): New, to factor the warnings for both C and C++ tests. Add -fno-color-diagnostics to it. * tests/local.at (AT_TEST_TABLES_AND_PARSE): Do not remove glue together compiler flags.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 14 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 289b2995..f10dabc1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -86,6 +86,12 @@ if test "$enable_gcc_warnings" = yes; then
-Wformat -Wpointer-arith -Wwrite-strings'
warn_c='-Wbad-function-cast -Wshadow -Wstrict-prototypes'
warn_cxx='-Wnoexcept'
+ # Warnings for the test suite only.
+ #
+ # -fno-color-diagnostics: Clang's use of colors in the error
+ # messages is confusing the tests looking at the compiler's output
+ # (e.g., synclines.at).
+ warn_tests='-Wundef -pedantic -fno-color-diagnostics'
AC_LANG_PUSH([C])
# Clang supports many of GCC's -W options, but only issues warnings
@@ -114,12 +120,13 @@ if test "$enable_gcc_warnings" = yes; then
AS_VAR_APPEND([WARN_CFLAGS], [" $WARN_CFLAGS_TEST"])
# Warnings for the test suite only.
- gl_WARN_ADD([-Wundef], [WARN_CFLAGS_TEST])
- gl_WARN_ADD([-pedantic], [WARN_CFLAGS_TEST])
+ for i in $warn_tests;
+ do
+ gl_WARN_ADD([$i], [WARN_CFLAGS_TEST])
+ done
CFLAGS=$save_CFLAGS
AC_LANG_POP([C])
-
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
gl_WARN_ADD([-Werror=unknown-warning-option], [CXXFLAGS])
@@ -131,8 +138,10 @@ if test "$enable_gcc_warnings" = yes; then
[AC_LANG_PROGRAM([], [nullptr])])
gl_WARN_ADD([-Werror], [WERROR_CXXFLAGS])
# Warnings for the test suite only.
- gl_WARN_ADD([-Wundef], [WARN_CXXFLAGS_TEST])
- gl_WARN_ADD([-pedantic], [WARN_CXXFLAGS_TEST])
+ for i in $warn_tests;
+ do
+ gl_WARN_ADD([$i], [WARN_CXXFLAGS_TEST])
+ done
# Clang++ 3.2+ reject C code generated by Flex.
gl_WARN_ADD([-Wno-null-conversion], [WARN_NO_NULL_CONVERSION_CXXFLAGS])
# Variants break strict aliasing analysis.