summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAkim Demaille <akim.demaille@gmail.com>2018-10-22 08:22:53 +0200
committerAkim Demaille <akim.demaille@gmail.com>2018-10-23 09:08:57 +0200
commitfacfd9c406fe4f304168e2702cd71fd1cbb3eab2 (patch)
tree664fce17048af3a8b593d43505646e08f9a98377 /configure.ac
parent0308dfb0395c44618cbc556d45cb34e74a531fb0 (diff)
downloadbison-facfd9c406fe4f304168e2702cd71fd1cbb3eab2.tar.gz
build: enable more warnings during tests
Prompted by Derek Clegg. http://lists.gnu.org/archive/html/bug-bison/2018-10/msg00018.html * configure.ac: here.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a569ef7c..f2240100 100644
--- a/configure.ac
+++ b/configure.ac
@@ -107,7 +107,9 @@ if test "$enable_gcc_warnings" = yes; then
# -Wno-keyword-macro: We use the "#define private public" dirty
# trick in the test suite to check some private implementation
# details for lalr1.cc.
- warn_tests='-Wundef -pedantic -Wdeprecated -Wsign-compare -fno-color-diagnostics
+ warn_tests='-Wundef -pedantic -Wconversion
+ -Wdeprecated -Wsign-compare -Wsign-conversion
+ -fno-color-diagnostics
-Wno-keyword-macro'
AC_LANG_PUSH([C])
@@ -137,7 +139,7 @@ if test "$enable_gcc_warnings" = yes; then
AS_VAR_APPEND([WARN_CFLAGS], [" $WARN_CFLAGS_TEST"])
# Warnings for the test suite only.
- for i in $warn_tests;
+ for i in $warn_tests -Wincompatible-pointer-types;
do
gl_WARN_ADD([$i], [WARN_CFLAGS_TEST])
done