summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-10-08 11:01:56 +0100
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2019-10-09 17:35:23 +0300
commit117c41242c01e057295aed80ed973c6dc7e35fe2 (patch)
treee135ff5e48d729fd6abf2a11be6954e091f8dd18 /Makefile.am
parent32e1f52469e197f40fc1124b938b6e2ccac35870 (diff)
downloadbluez-117c41242c01e057295aed80ed973c6dc7e35fe2.tar.gz
Makefile.am: add missing mkdir in rules generation
In parallel out-of-tree builds it's possible that tools/*.rules are generated before the target directory has been implicitly created. Solve this by creating the directory before writing into it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 2ac28b23d..e7bcd2366 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -589,6 +589,7 @@ src/builtin.h: src/genbuiltin $(builtin_sources)
$(AM_V_GEN)$(srcdir)/src/genbuiltin $(builtin_modules) > $@
tools/%.rules:
+ $(AM_V_at)$(MKDIR_P) tools
$(AM_V_GEN)cp $(srcdir)/$(subst 97-,,$@) $@
$(lib_libbluetooth_la_OBJECTS): $(local_headers)