summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiao-chen Chou <mcchou@chromium.org>2020-09-11 23:51:21 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2020-09-14 12:34:34 -0700
commit1b32562b7075570d63ebbcc534aca6b0102353fa (patch)
treea80ddd8abf3b7362eb602608256526ab290e9d04 /Makefile.am
parent1a515e154e524010cfa5a56f1be13bdab3009024 (diff)
downloadbluez-1b32562b7075570d63ebbcc534aca6b0102353fa.tar.gz
adv_monitor: Introduce org.bluez.AdvertisementMonitorManager1 interface
This introduces the org.bluez.AdvertisementMonitorManager1 without implementing handlers of methods and properties. The following test was performed. - Upon adapter registration, the info line of creating an ADV monitor manager gets printed, and system bus emits the interface events of org.bluez.AdvertisementMonitorManager1.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 725fbe48d..22b4fa30c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -293,7 +293,8 @@ src_bluetoothd_SOURCES = $(builtin_sources) \
src/gatt-client.h src/gatt-client.c \
src/device.h src/device.c \
src/dbus-common.c src/dbus-common.h \
- src/eir.h src/eir.c
+ src/eir.h src/eir.c \
+ src/adv_monitor.h src/adv_monitor.c
src_bluetoothd_LDADD = lib/libbluetooth-internal.la \
gdbus/libgdbus-internal.la \
src/libshared-glib.la \