summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2022-11-03 14:59:51 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2022-11-15 11:22:39 -0800
commit1ebbfee345171cb4d38ae55501849a5671d2df4a (patch)
treef4651cf8fcc3555c5b029cb57f902d7552ebed2b /Makefile.am
parent7fcd6889fb13858e3f78e9d5e35ffd80d8e0accb (diff)
downloadbluez-1ebbfee345171cb4d38ae55501849a5671d2df4a.tar.gz
unit: Introduce test-bap
Test Summary ------------ BAP/UCL/DISC/BV-01-C Passed BAP/UCL/DISC/BV-02-C Passed BAP/UCL/DISC/BV-06-C Passed BAP/UCL/DISC/BV-05-C Passed BAP/UCL/DISC/BV-03-C Passed BAP/UCL/DISC/BV-04-C Passed Total: 6, Passed: 6 (100.0%), Failed: 0, Not Run: 0
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 7041f8eeb..aa3a5e053 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -569,6 +569,12 @@ unit_test_gattrib_LDADD = lib/libbluetooth-internal.la \
src/libshared-glib.la \
$(GLIB_LIBS) $(DBUS_LIBS) -ldl -lrt
+unit_tests += unit/test-bap
+
+unit_test_bap_SOURCES = unit/test-bap.c
+unit_test_bap_LDADD = src/libshared-glib.la \
+ lib/libbluetooth-internal.la $(GLIB_LIBS)
+
if MIDI
unit_tests += unit/test-midi
unit_test_midi_CPPFLAGS = $(AM_CPPFLAGS) $(ALSA_CFLAGS) -DMIDI_TEST