summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBrian Gix <brian.gix@intel.com>2019-11-05 14:49:10 -0800
committerBrian Gix <brian.gix@intel.com>2019-11-07 09:17:00 -0800
commit4f4ac13ef6cc2f31d102f178117beb9e40a9378e (patch)
tree370c965abd17f133eaff3395843a48339fcaa35a /Makefile.am
parent29c1ed83bc0f47c9545261a3a8bd284af902febe (diff)
downloadbluez-4f4ac13ef6cc2f31d102f178117beb9e40a9378e.tar.gz
unit: Fixed Mesh Crypto unit test build for LTO
Was erroneously compiling and linking explicit unit test versions of the ELL source dependancies while also linking with the library made from same sources. This created Link Time Optimization (LTO) problems when calling exit(), as there were two copies of the constructors and destructors from ell/log.c.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 2 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 84c9712c9..8d419fb30 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -524,10 +524,8 @@ if MESH
unit_tests += unit/test-mesh-crypto
unit_test_mesh_crypto_CPPFLAGS = $(ell_cflags)
unit_test_mesh_crypto_SOURCES = unit/test-mesh-crypto.c \
- mesh/crypto.h ell/internal ell/ell.h \
- $(ell_sources)
-unit_test_mesh_crypto_LDADD = src/libshared-ell.la \
- $(ell_ldadd)
+ mesh/crypto.h ell/internal ell/ell.h
+unit_test_mesh_crypto_LDADD = $(ell_ldadd)
endif
if MAINTAINER_MODE