summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2019-10-16 11:57:23 +0300
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2019-10-16 11:57:23 +0300
commit8812296c864ad96ba0c9f238b21ca1e59f0f3e2a (patch)
tree8acfa81be8aac0e1d203e648df63743483e12d7b /Makefile.am
parent9a6ffbbb88d8fb80f6e086e3da264b3505dfc904 (diff)
downloadbluez-8812296c864ad96ba0c9f238b21ca1e59f0f3e2a.tar.gz
unit: Make mesh tests conditional
Mesh code can be disabled with use of --disable-mesh.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e7bcd2366..84c9712c9 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -520,6 +520,7 @@ unit_test_midi_LDADD = src/libshared-glib.la \
$(GLIB_LIBS) $(ALSA_LIBS)
endif
+if MESH
unit_tests += unit/test-mesh-crypto
unit_test_mesh_crypto_CPPFLAGS = $(ell_cflags)
unit_test_mesh_crypto_SOURCES = unit/test-mesh-crypto.c \
@@ -527,6 +528,7 @@ unit_test_mesh_crypto_SOURCES = unit/test-mesh-crypto.c \
$(ell_sources)
unit_test_mesh_crypto_LDADD = src/libshared-ell.la \
$(ell_ldadd)
+endif
if MAINTAINER_MODE
noinst_PROGRAMS += $(unit_tests)