summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2018-02-21 13:24:41 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2018-02-22 11:52:16 +0200
commita287cb4229a9120c32d30efd43e84b04f5440d05 (patch)
tree82c9bec04f40fa6c38bee3f77067ed2fce5b0061 /Makefile.am
parentfd656b1ce371b68a4df7bd4fa5ca41ae238e36de (diff)
downloadbluez-a287cb4229a9120c32d30efd43e84b04f5440d05.tar.gz
shared/mainloop: Add GLIB wrapper
This adds wrappers function to interface with GLIB mainloop so applications can use mainloop functions no matter what is the underline implementation. Note: Most functions are not actually implemented on purpose since both io and timeout functions already exists for GLIB covering the same functionality.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 02f02a100..daf34b6ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -123,7 +123,8 @@ shared_sources = src/shared/io.h src/shared/timeout.h \
src_libshared_glib_la_SOURCES = $(shared_sources) \
src/shared/io-glib.c \
- src/shared/timeout-glib.c
+ src/shared/timeout-glib.c \
+ src/shared/mainloop-glib.c
src_libshared_mainloop_la_SOURCES = $(shared_sources) \
src/shared/io-mainloop.c \