summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorTedd Ho-Jeong An <tedd.an@intel.com>2021-04-28 15:56:50 -0700
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2021-04-30 17:40:57 -0700
commitb055779642a43c43c07c3e5e73d9b8677e1dc364 (patch)
treeb277846c0518ab367ef3fb6bef4b438d84b34219 /Makefile.am
parentd9fdbedf0ee3a5981e2d83d85b547b7750303acb (diff)
downloadbluez-b055779642a43c43c07c3e5e73d9b8677e1dc364.tar.gz
Build: Add missing ELL headers and sources
The recent change in ELL included the header file tls.h which didn't included in the BlueZ. This patch adds a series of missing ELL headers and sources to align with the change in ELL.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 14 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 319331bb2..2a222167f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -140,7 +140,12 @@ ell_headers = ell/util.h \
ell/uuid.h \
ell/useful.h \
ell/main-private.h \
- ell/tester.h
+ ell/tester.h \
+ ell/tls.h \
+ ell/tls-private.h \
+ ell/ecc.h \
+ ell/ecc-private.h \
+ ell/ecdh.h
ell_sources = ell/private.h ell/missing.h \
ell/util.c \
@@ -178,7 +183,14 @@ ell_sources = ell/private.h ell/missing.h \
ell/siphash-private.h \
ell/siphash.c \
ell/uuid.c \
- ell/tester.c
+ ell/tester.c \
+ ell/tls.c \
+ ell/tls-extensions.c \
+ ell/tls-suites.c \
+ ell/tls-record.c \
+ ell/ecc.c \
+ ell/ecc-external.c \
+ ell/ecdh.c
ell_shared = ell/useful.h