summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorInga Stotland <inga.stotland@intel.com>2021-02-12 13:42:42 -0800
committerBrian Gix <brian.gix@intel.com>2021-02-16 11:51:00 -0800
commitbc65e8840dcf2c3c42f5cefed7cc1ea9e0ff3669 (patch)
treee81ac8cdffff087513958bbe342c91a576cafc91 /Makefile.am
parent400e738bf07b5950460e3246af343a1737918481 (diff)
downloadbluez-bc65e8840dcf2c3c42f5cefed7cc1ea9e0ff3669.tar.gz
mesh: Add validation of Device UUID value
Validate that the value of Device UUID supplied in CreateNetwork/Join/Import methods is compliant with RFC 4122.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index d0f979586..86f3409c3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -134,7 +134,8 @@ ell_headers = ell/util.h \
ell/base64.h \
ell/asn1-private.h \
ell/cert-private.h \
- ell/pem-private.h
+ ell/pem-private.h \
+ ell/uuid.h
ell_sources = ell/private.h ell/missing.h \
ell/util.c \
@@ -169,7 +170,8 @@ ell_sources = ell/private.h ell/missing.h \
ell/gvariant-private.h \
ell/gvariant-util.c \
ell/siphash-private.h \
- ell/siphash.c
+ ell/siphash.c \
+ ell/uuid.c
ell_libell_internal_la_SOURCES = $(ell_headers) $(ell_sources)
endif