summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2021-04-02 07:26:29 +0200
committerMarcel Holtmann <marcel@holtmann.org>2021-04-02 07:26:29 +0200
commitfde1e8fbf40a844b674be1b25ff6e64b3449a65e (patch)
treea311a3f5c099e9be3bc95522b2f9df2584ee908a /Makefile.am
parent3f4039f43ba02418452edab7aab374e17dce6c8e (diff)
downloadbluez-fde1e8fbf40a844b674be1b25ff6e64b3449a65e.tar.gz
build: Always link in the ell/useful.h header file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 7fce2e7c0..444623649 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -100,12 +100,12 @@ if EXTERNAL_ELL
ell_cflags = @ELL_CFLAGS@
ell_ldadd = @ELL_LIBS@
ell_dependencies =
-ell_built_sources =
+ell_built_sources = ell/shared
else
ell_cflags =
ell_ldadd = ell/libell-internal.la
ell_dependencies = $(ell_ldadd)
-ell_built_sources = ell/internal ell/ell.h
+ell_built_sources = ell/shared ell/internal ell/ell.h
noinst_LTLIBRARIES += ell/libell-internal.la
@@ -136,7 +136,6 @@ ell_headers = ell/util.h \
ell/cert-private.h \
ell/pem-private.h \
ell/uuid.h \
- ell/useful.h \
ell/main-private.h
ell_sources = ell/private.h ell/missing.h \
@@ -175,7 +174,9 @@ ell_sources = ell/private.h ell/missing.h \
ell/siphash.c \
ell/uuid.c
-ell_libell_internal_la_SOURCES = $(ell_headers) $(ell_sources)
+ell_shared = ell/useful.h
+
+ell_libell_internal_la_SOURCES = $(ell_headers) $(ell_sources) $(ell_shared)
endif
CLEANFILES += $(ell_built_sources)
@@ -618,6 +619,13 @@ lib/bluetooth/%.h: lib/%.h
$(AM_V_at)$(MKDIR_P) lib/bluetooth
$(AM_V_GEN)$(LN_S) -f $(abspath $<) $@
+ell/shared: Makefile
+ $(AM_V_GEN)for f in $(ell_shared) ; do \
+ if [ ! -f $$f ] ; then \
+ $(LN_S) -t ell -f $(abs_srcdir)/../ell/$$f ; \
+ fi \
+ done > $@
+
ell/internal: Makefile
$(AM_V_at)$(MKDIR_P) ell
$(AM_V_GEN)for f in $(ell_headers) $(ell_sources) ; do \