summaryrefslogtreecommitdiff
path: root/android/Makefile.am
diff options
context:
space:
mode:
authorAndrei Emeltchenko <andrei.emeltchenko@intel.com>2015-02-20 14:43:15 +0200
committerSzymon Janc <szymon.janc@tieto.com>2015-02-22 21:26:25 +0100
commit37c942ff2ba1fc4e42a95957c8f24c19e468d4f0 (patch)
tree92c2c12f6d0e2fc8108c61eec2aefd418fd3320a /android/Makefile.am
parent49450bf6f01f8f08ee585bda8f75ac7d7f40d0af (diff)
downloadbluez-37c942ff2ba1fc4e42a95957c8f24c19e468d4f0.tar.gz
android/avdtp: Refactor local SEP list handling
In order to deduplicate similar code in android/ and profiles/ we need to handle local SEP queue outside of avdtp.c. GSList is transformed to queue.
Diffstat (limited to 'android/Makefile.am')
-rw-r--r--android/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/android/Makefile.am b/android/Makefile.am
index bb8ea9e97..3ea32e9c7 100644
--- a/android/Makefile.am
+++ b/android/Makefile.am
@@ -103,6 +103,7 @@ android_avdtptest_SOURCES = android/avdtptest.c \
src/log.h src/log.c \
btio/btio.h btio/btio.c \
src/shared/util.h src/shared/util.c \
+ src/shared/queue.h src/shared/queue.c \
android/avdtp.h android/avdtp.c
android_avdtptest_CFLAGS = $(AM_CFLAGS)
android_avdtptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@