summaryrefslogtreecommitdiff
path: root/android/Makefile.am
diff options
context:
space:
mode:
authorLukasz Rymanowski <lukasz.rymanowski@tieto.com>2014-09-15 13:51:17 +0200
committerSzymon Janc <szymon.janc@tieto.com>2014-09-18 16:36:04 +0200
commit8809f1970e1ddfcd777b00a616a802c0fbc7a222 (patch)
tree9a3181235eae14fd054c0eb1e5ac3cd0760f20f6 /android/Makefile.am
parent4056566559c1f5ace7a2369bc1322965898bc568 (diff)
downloadbluez-8809f1970e1ddfcd777b00a616a802c0fbc7a222.tar.gz
android/handsfree-client: Add handsfree-client HAL skeleton
This patch also introduce BLUEZ_EXTENSIONS flag which is used for not Android AOSP features like HF Client in this case. Idea is that BfA for PC is always build with this flag and it is added to Makefile.am For Android there is need to set this flag as described in README
Diffstat (limited to 'android/Makefile.am')
-rw-r--r--android/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/android/Makefile.am b/android/Makefile.am
index 70b9c3a45..b576fda21 100644
--- a/android/Makefile.am
+++ b/android/Makefile.am
@@ -75,6 +75,7 @@ android_bluetooth_default_la_SOURCES = android/hal.h android/hal-bluetooth.c \
android/hal-a2dp.c \
android/hal-avrcp.c \
android/hal-handsfree.c \
+ android/hal-handsfree-client.c \
android/hal-gatt.c \
android/hardware/bluetooth.h \
android/hardware/bt_av.h \
@@ -88,6 +89,7 @@ android_bluetooth_default_la_SOURCES = android/hal.h android/hal-bluetooth.c \
android/hardware/bt_pan.h \
android/hardware/bt_rc.h \
android/hardware/bt_sock.h \
+ android/hardware/bt_hf_client.h \
android/hardware/hardware.h \
android/cutils/properties.h \
android/ipc-common.h \
@@ -95,7 +97,7 @@ android_bluetooth_default_la_SOURCES = android/hal.h android/hal-bluetooth.c \
android/hal-ipc.h android/hal-ipc.c \
android/hal-utils.h android/hal-utils.c
-android_bluetooth_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android
+android_bluetooth_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android -DBLUEZ_EXTENSIONS
android_bluetooth_default_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-no-undefined