summaryrefslogtreecommitdiff
path: root/android/Makefile.am
diff options
context:
space:
mode:
authorMarcel Holtmann <marcel@holtmann.org>2014-09-25 13:01:43 +0200
committerMarcel Holtmann <marcel@holtmann.org>2014-09-25 13:01:43 +0200
commit9b912ea92537cf9add1e50fac54fd58f80db9c6b (patch)
tree5dda2b388b5331846d3c5d08b0ae58f23d6ab4d4 /android/Makefile.am
parente4424b2aed4df92139133850a7edc25d35ce2f8d (diff)
downloadbluez-9b912ea92537cf9add1e50fac54fd58f80db9c6b.tar.gz
build: Use internal libshared-glib and libshared-mainloop libraries
Diffstat (limited to 'android/Makefile.am')
-rw-r--r--android/Makefile.am86
1 files changed, 20 insertions, 66 deletions
diff --git a/android/Makefile.am b/android/Makefile.am
index 59caf61ac..214082c18 100644
--- a/android/Makefile.am
+++ b/android/Makefile.am
@@ -6,14 +6,13 @@ android_plugindir = $(abs_top_srcdir)/android/.libs
noinst_PROGRAMS += android/system-emulator
-android_system_emulator_SOURCES = android/system-emulator.c \
- monitor/mainloop.h monitor/mainloop.c
+android_system_emulator_SOURCES = android/system-emulator.c
+android_system_emulator_LDADD = src/libshared-mainloop.la
noinst_PROGRAMS += android/bluetoothd-snoop
-android_bluetoothd_snoop_SOURCES = android/bluetoothd-snoop.c \
- monitor/mainloop.h monitor/mainloop.c \
- src/shared/btsnoop.h src/shared/btsnoop.c
+android_bluetoothd_snoop_SOURCES = android/bluetoothd-snoop.c
+android_bluetoothd_snoop_LDADD = src/libshared-mainloop.la
noinst_PROGRAMS += android/bluetoothd
@@ -27,15 +26,6 @@ android_bluetoothd_SOURCES = android/main.c \
src/sdpd-service.c src/sdpd-request.c \
src/uuid-helper.h src/uuid-helper.c \
src/eir.h src/eir.c \
- src/shared/io.h src/shared/io-glib.c \
- src/shared/queue.h src/shared/queue.c \
- src/shared/util.h src/shared/util.c \
- src/shared/mgmt.h src/shared/mgmt.c \
- src/shared/ringbuf.h src/shared/ringbuf.c \
- src/shared/hfp.h src/shared/hfp.c \
- src/shared/gatt-db.h src/shared/gatt-db.c \
- src/shared/crypto.h src/shared/crypto.c \
- src/shared/uhid.h src/shared/uhid.c \
android/bluetooth.h android/bluetooth.c \
android/hidhost.h android/hidhost.c \
android/scpp.h android/scpp.c \
@@ -62,8 +52,8 @@ android_bluetoothd_SOURCES = android/main.c \
btio/btio.h btio/btio.c \
src/sdp-client.h src/sdp-client.c \
profiles/network/bnep.h profiles/network/bnep.c
-
-android_bluetoothd_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
+android_bluetoothd_LDADD = lib/libbluetooth-internal.la \
+ src/libshared-glib.la @GLIB_LIBS@
plugin_LTLIBRARIES += android/bluetooth.default.la
@@ -96,7 +86,6 @@ android_bluetooth_default_la_SOURCES = android/hal.h android/hal-bluetooth.c \
android/hal-log.h \
android/hal-ipc.h android/hal-ipc.c \
android/hal-utils.h android/hal-utils.c
-
android_bluetooth_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android
android_bluetooth_default_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-no-undefined
@@ -107,9 +96,7 @@ android_mcaptest_SOURCES = android/mcaptest.c \
src/log.h src/log.c \
btio/btio.h btio/btio.c \
android/mcap-lib.h android/mcap-lib.c
-
android_mcaptest_CFLAGS = $(AM_CFLAGS)
-
android_mcaptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
noinst_PROGRAMS += android/avdtptest
@@ -118,9 +105,7 @@ android_avdtptest_SOURCES = android/avdtptest.c \
src/log.h src/log.c \
btio/btio.h btio/btio.c \
android/avdtp.h android/avdtp.c
-
android_avdtptest_CFLAGS = $(AM_CFLAGS)
-
android_avdtptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
noinst_PROGRAMS += android/haltest
@@ -147,10 +132,8 @@ android_haltest_SOURCES = android/client/haltest.c \
android/client/if-sco.c \
android/hardware/hardware.c \
android/hal-utils.h android/hal-utils.c
-
android_haltest_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android \
-DPLUGINDIR=\""$(android_plugindir)"\"
-
android_haltest_LDFLAGS = -pthread -ldl -lm
noinst_PROGRAMS += android/android-tester
@@ -158,14 +141,6 @@ noinst_PROGRAMS += android/android-tester
android_android_tester_SOURCES = emulator/btdev.h emulator/btdev.c \
emulator/bthost.h emulator/bthost.c \
emulator/smp.c \
- src/shared/crypto.h src/shared/crypto.c \
- src/shared/io.h src/shared/io-glib.c \
- src/shared/queue.h src/shared/queue.c \
- src/shared/util.h src/shared/util.c \
- src/shared/mgmt.h src/shared/mgmt.c \
- src/shared/hciemu.h src/shared/hciemu.c \
- src/shared/tester.h src/shared/tester.c \
- src/shared/timeout.h src/shared/timeout-glib.c \
monitor/rfcomm.h \
android/hardware/hardware.c \
android/tester-bluetooth.c \
@@ -177,12 +152,10 @@ android_android_tester_SOURCES = emulator/btdev.h emulator/btdev.c \
android/tester-avrcp.c \
android/tester-gatt.c \
android/tester-main.h android/tester-main.c
-
android_android_tester_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android \
-DPLUGINDIR=\""$(android_plugindir)"\"
-
-android_android_tester_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
-
+android_android_tester_LDADD = lib/libbluetooth-internal.la \
+ src/libshared-glib.la @GLIB_LIBS@
android_android_tester_LDFLAGS = -pthread -ldl
noinst_PROGRAMS += android/ipc-tester
@@ -190,20 +163,13 @@ noinst_PROGRAMS += android/ipc-tester
android_ipc_tester_SOURCES = emulator/btdev.h emulator/btdev.c \
emulator/bthost.h emulator/bthost.c \
emulator/smp.c \
- src/shared/crypto.h src/shared/crypto.c \
- src/shared/io.h src/shared/io-glib.c \
- src/shared/queue.h src/shared/queue.c \
- src/shared/util.h src/shared/util.c \
- src/shared/mgmt.h src/shared/mgmt.c \
- src/shared/hciemu.h src/shared/hciemu.c \
- src/shared/tester.h src/shared/tester.c \
- src/shared/timeout.h src/shared/timeout-glib.c \
android/hal-utils.h android/hal-utils.c \
android/ipc-common.h android/ipc-tester.c
-
android_ipc_tester_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android
+android_ipc_tester_LDADD = lib/libbluetooth-internal.la \
+ src/libshared-glib.la @GLIB_LIBS@
-android_ipc_tester_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
+plugin_LTLIBRARIES += android/audio.a2dp.default.la
android_audio_a2dp_default_la_SOURCES = android/audio-msg.h \
android/hal-msg.h \
@@ -214,9 +180,14 @@ android_audio_a2dp_default_la_SOURCES = android/audio-msg.h \
android/hardware/audio.h \
android/hardware/audio_effect.h \
android/hardware/hardware.h \
- android/system/audio.h \
- src/shared/queue.h \
- src/shared/queue.c
+ android/system/audio.h
+android_audio_a2dp_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android \
+ @SBC_CFLAGS@
+android_audio_a2dp_default_la_LIBADD = src/libshared-mainloop.la @SBC_LIBS@
+android_audio_a2dp_default_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
+ -no-undefined -pthread -lrt
+
+plugin_LTLIBRARIES += android/audio.sco.default.la
android_audio_sco_default_la_SOURCES = android/hal-log.h \
android/sco-msg.h \
@@ -227,34 +198,17 @@ android_audio_sco_default_la_SOURCES = android/hal-log.h \
android/audio_utils/resampler.c \
android/audio_utils/resampler.h \
android/system/audio.h
-
android_audio_sco_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android
-
android_audio_sco_default_la_LIBADD = @SPEEXDSP_LIBS@
-
android_audio_sco_default_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
-no-undefined -lrt
-
-plugin_LTLIBRARIES += android/audio.sco.default.la
-
unit_tests += android/test-ipc
android_test_ipc_SOURCES = android/test-ipc.c \
- src/shared/util.h src/shared/util.c \
src/log.h src/log.c \
android/ipc-common.h \
android/ipc.c android/ipc.h
-android_test_ipc_LDADD = @GLIB_LIBS@
-
-plugin_LTLIBRARIES += android/audio.a2dp.default.la
-
-android_audio_a2dp_default_la_CFLAGS = $(AM_CFLAGS) -I$(srcdir)/android \
- @SBC_CFLAGS@
-
-android_audio_a2dp_default_la_LIBADD = @SBC_LIBS@
-
-android_audio_a2dp_default_la_LDFLAGS = $(AM_LDFLAGS) -module -avoid-version \
- -no-undefined -pthread -lrt
+android_test_ipc_LDADD = src/libshared-glib.la @GLIB_LIBS@
endif