summaryrefslogtreecommitdiff
path: root/android/Makefile.am
diff options
context:
space:
mode:
authorAndrei Emeltchenko <andrei.emeltchenko@intel.com>2015-02-16 15:02:26 +0200
committerLuiz Augusto von Dentz <luiz.von.dentz@intel.com>2015-02-19 15:21:08 +0200
commitc4686d50860e18abff8bdaaa77d20d1b783801ae (patch)
tree200edd43877a8264748882f1191a971999587775 /android/Makefile.am
parentdbcd2d44466b35860bb335bd5c8789e7b2a858bb (diff)
downloadbluez-c4686d50860e18abff8bdaaa77d20d1b783801ae.tar.gz
android/avdtp: Fix SEID generation
Fixes SEID generation for avdtp. Currently SEIDs were assigned assuming that SEID are registered and unregistered in the same order like: seid = g_slist_length(seps) + 1 which makes it possible to reuse similar SEIDs. Note that helper function allows maximum id of sizeof(int) * 8 which is smaller then MAX_SEID but more then enough for local SEPs.
Diffstat (limited to 'android/Makefile.am')
-rw-r--r--android/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/android/Makefile.am b/android/Makefile.am
index 4f13c4dd0..f8c76b389 100644
--- a/android/Makefile.am
+++ b/android/Makefile.am
@@ -102,6 +102,7 @@ noinst_PROGRAMS += android/avdtptest
android_avdtptest_SOURCES = android/avdtptest.c \
src/log.h src/log.c \
btio/btio.h btio/btio.c \
+ src/shared/util.h src/shared/util.c \
android/avdtp.h android/avdtp.c
android_avdtptest_CFLAGS = $(AM_CFLAGS)
android_avdtptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@