summaryrefslogtreecommitdiff
path: root/android/Makefile.am
diff options
context:
space:
mode:
authorSzymon Janc <szymon.janc@tieto.com>2014-08-21 15:33:21 +0200
committerSzymon Janc <szymon.janc@tieto.com>2014-09-01 15:54:16 +0200
commitffe06d0391a6ba836a12ebb037766322a0e6919a (patch)
tree43fea84f8181dfabfb05a942a9247a89dd21e825 /android/Makefile.am
parentf3686a7fb09b58683a38ba7bcd1847a111175a6e (diff)
downloadbluez-ffe06d0391a6ba836a12ebb037766322a0e6919a.tar.gz
android: Add initial code for AVDTP testing tool
This tools is intended for AVDTP qualification with PTS.
Diffstat (limited to 'android/Makefile.am')
-rw-r--r--android/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/android/Makefile.am b/android/Makefile.am
index 4b93c5b2a..e93a08be8 100644
--- a/android/Makefile.am
+++ b/android/Makefile.am
@@ -109,6 +109,17 @@ android_mcaptest_CFLAGS = $(AM_CFLAGS)
android_mcaptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
+noinst_PROGRAMS += android/avdtptest
+
+android_avdtptest_SOURCES = android/avdtptest.c \
+ src/log.h src/log.c \
+ btio/btio.h btio/btio.c \
+ android/avdtp.h android/avdtp.c
+
+android_avdtptest_CFLAGS = $(AM_CFLAGS)
+
+android_avdtptest_LDADD = lib/libbluetooth-internal.la @GLIB_LIBS@
+
noinst_PROGRAMS += android/haltest
android_haltest_SOURCES = android/client/haltest.c \